I feel realy dumb. I have openhab running with demo and I have also creatd a default site map. Both work great. I am using it on my raspberry pi. Now I want to learn more about the openHAB-Designer. That is where my troubles start.

I am logged in as root user I am in the openhab-desinger folder I can see openHAB-Designer program there I type openHAB-Designer to start and I get a error back “command not found”

Help and thnx.

Try ./openHAB-Designer

On Linux, unless you explicitly edit your path to include it, does not have your current directory in your path. Since it only checks your path to find executables it never finds it.

Designer should be used on your desktop system, are you using the pi with a desktop manager?

I have the pi with the desk top gui and can run it through a vnc connection.

In that case you can do as @rlkoshak said, open a terminal, go to the Designer directory and start it with ./openHAB-Designer , however, you may prefer to use the Designer on the desktop from where you’re using the vnc client, for that you’ll need to share the configuration files with samba, there’s a tutorial here.

I thought I had tried that before. Just went to my openhab-designer directory and tried it again. I get this error.

cannot execcute binary file: Exec format error

I think we are on the right path but some thing is wrong either in the init file or something.

Tom C


Did you download the correct version of openHAB? I think you need the Linux 32 bit version on the Pi.

Thanks Rich. I sort of found my problem.

I run openhab on my pi. I had openhab-desinger on my pi also. That did not work at all because the bin file was compiled on regular linux.

So I put openhab-designer on my laptop linux machine. Now it at least starts to open then crashes. I have not looked into this yet.

Thanks all will get back later.

Folks, is it possible to run openhab-designer right ON the raspberry pi 2?
I would like to have the Rpi 2 be self-contained and have everything run on it, accessible via vnc (the vnc part is working fine).

I’m new to Openhab and Rpi (and linux, and…) so I something obvious might be lost on me.

I try running openhab-designer from /opt/openhab-designer/openhab-designer where I extracted it but nothing happens. I extracted 1.7.1 version for Linux (32).


Yes you should be able to run it but you may need to run it as root. I know I have to on my Ubuntu install. I’ve never really looked into why or whether there is another way.

Run it from the command line and look for errors.

According to this (old) post it is not possible as it is built for the X86 architecture…