openHAB docker: Error initializing storage for Equinox container


I update every now and then my raspberry pi is currently running Bullseye.

My setup:

  • running openHAB 3.2 in a docker instance (openhab/openhab:latest) on Raspberry Pi (32bit)

I followed the docker compose example from here:

My docker-compose.yaml looks like this:

        container_name: openhab
        image: openhab/openhab:3.2.0
        restart: always
            #- 8080:8080
            #- 8443:8443
            - ./openhab/addons:/openhab/addons
            - ./openhab/conf:/openhab/conf
            - ./openhab/userdata:/openhab/userdata
            OPENHAB_HTTP_PORT: "8080"
            OPENHAB_HTTPS_PORT: "8443"
            EXTRA_JAVA_OPTS: "-Duser.timezone=Germany/Berlin"
            - /dev/ttyACM0
            #- influxdb-telegraf-net
        network_mode: "host"

My docker logs openhab returns this:

Launching the openHAB runtime...
Error initializing storage for Equinox container.

I’m running the plain docker image and i have no idea where to start.

Which Java version is being used ? I see several reports for this error message that are being caused by using the wrong Java version.

That’s the point - I can’t figure out which Java version is used in the docker image. Via docker-compose up -d the image is set to start up. Before running it restarts with the error. On my host machine Java 11 is installed.

I’m fairly new to docker but my setup worked effortlessly a couple of days ago. Unfortunately I have no backup …

There have been a number of changes to Docker recently where they have dropped support for some file systems. When I recently upgraded docker on my Ubuntu servers I had to stop the containers, delete the aufs files stores and recreate them with overlay2. See linux - How to move images of docker in aufs directory to overlay2? - Stack Overflow

Beyond that, I’m not sure what could be wrong. I don’t think it’s a Java version as the Docker Image comes with a compatible Java. But some more googling shows it should be a permissions problem.

@rlkoshak thanks for your input.

I fixed it myself by recreating the container, so now it works with 3.2.0