Openhab Docker Interface Binding

i have deployed an openHAB instance in Docker (, and started the openHAB Docker with parameter --net=host.
In logfile i have found that openhab found 4 Interfaces, and ingores 3 of them - but binds the Dahsboard to the wrong interface.
i allready tried to edit org.ops4j.pax.web.cfg in “userdata/etc”, but after restart nothing has changed in log file (org.ops4j.pax.web.listening.addresses = “ip address”)

is there another config or maybe a environment parameter i have to change to bind openHAB in Docker to a specific ip address?

many thanks for help


I have exactly the same problem and tried to find out where I can set up the binding interface for the Dashboard.

I use the OpenHAB docker version 2.3.0-amd64-debian and the interface used is the docker bridge, which is un reachable from my desktop. Aka I can not connect to the Dashboard.

Here are the logs:
2018-10-28 10:18:09.714 [WARN ] [] - Found multiple local interfaces - ignoring
2018-10-28 10:18:09.720 [WARN ] [] - Found multiple local interfaces - ignoring
2018-10-28 10:18:12.717 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2018-10-28 10:18:13.351 [WARN ] [] - Found multiple local interfaces - ignoring
2018-10-28 10:18:13.352 [WARN ] [] - Found multiple local interfaces - ignoring
2018-10-28 10:18:13.363 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2018-10-28 10:18:13.364 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at

Has someone fixed this? I run into the same problem.

any solution ?

on windows I found a solution.

I use this parameters in start.bat:


After that OH only listen to ip-address and HTTPS-port is changed to 8448. The log file tells, that more ip-addresses are found and only one is used. This message is wrong, but if I check it with netstat -a all went as exspected.

Editing /var/lib/openhab2/config/org/eclipse/smarthome/network.config gives a solution too, and is dynamic
Parameter setting

Having the same problem. Dashboard is always connecting to the wrong IP address. Changing network.config did not make a difference. Any more ideas how to fix this?

Without being able to bind OH to the correct network, the Docker implementation is pretty useless…

1 Like

Has anyone found a fix for this?
Changing the network.config file doesnt do anything for me, the behaviour stays exactly the same.
Openhab is still ignoring 3 interfaces and choosing the wrong one

How about setting the address of the interface you want in Paper UI -> Configuration -> System -> Network Settings -> Primary Address?