[openHAB Docker] "/usr/share/openhab/addons does not exist" after upgrade to OH 3.3.0

  • Platform information:
    • Hardware: Intel(R) Celeron(R) CPU J3455 @ 1.50GHz / 16 GB RAM
    • OS: TrueNAS-SCALE-22.02.2-MASTER-20220617-041230
    • openHAB version: 3.3.0 Release
  • Issue of the topic:
    • After the update of openHAB to 3.3.0 Release via Image openhab/openhab:latest-alpine (pushed yesterday by @wborn?) all my Things were showing state uninitialized
    • UI is reachable
  • If logs where generated please post these here using code fences:

I was restarting my containers and this was the first thing that came up

2022-06-28 11:43:41.224 [INFO ] [org.openhab.ui.internal.UIService   ] - Stopped UI
2022-06-28 11:44:24.483 [WARN ] [org.apache.felix.fileinstall        ] - /usr/share/openhab/addons does not exist, please create it.
2022-06-28 11:44:24.501 [WARN ] [org.apache.felix.fileinstall        ] - Root path does not exist: /usr/share/openhab/addons

So i checked if usr/share/openhab/addons does exist
There is no such folder

Have there changes been made which i did not see?
I did not change anything to my setup and first thought about file permissions, but then i found out that the folder really is not present

Sorry if i missed changes for this release or something

For additional informatin, here some of my mounted volumes (docker-compose):

volumes:
  - "/etc/localtime:/etc/localtime:ro"
  - "/etc/timezone:/etc/timezone:ro"
  - "/mypath/openhab_addons:/openhab/addons"
  - "/mypath/openhab_conf:/openhab/conf"
  - "/mypath/openhab_userdata:/openhab/userdata"

I could try to go back to an older image if it helps

Thanks in advance

OK, going back to 3.2.0-alpine fixed the issue for me.
Not sure if i changes are necessary for using 3.3.0

Thanks

Maybe you’re using data that was previously used with an APT (Debian/Raspbian/openHABian) installation?

Then it is expected that you run into such issues because the containers use different paths, see also:

To fix it you have to manually update these paths in your userdata.

Im not a professional user but im 100% sure that i only use the openhab/openhab:x-alpine images for a long time now

I temporarily fixed my system by rolling back to

  • openhab/openhab:3.2.0-alpine image
  • Restored my mounted volumes via a backup tool

Restarted my services and everything is running fine now again.

This tells me that my “old restored data” from 3 days ago is running fine on alpine image

If this is helpful for you i could test to go back to openhab/openhab:3.3.0-alpine and provide you the logs or something

If everything runs fine the error may be on my side (despite the fact that i did not touch anything)

Do find any results when you search for that path on your userdata, e.g. by executing the following command in the container?

grep -R '/usr/share/openhab/addons' /openhab/userdata
1 Like
bash-5.1# grep -R '/usr/share/openhab/addons' /openhab/userdata
/openhab/userdata/logs/openhab.log:2022-06-28 18:19:49.991 [WARN ] [org.apache.felix.fileinstall        ] - /usr/share/openhab/addons does not exist, please create it.
/openhab/userdata/logs/openhab.log:2022-06-28 18:19:50.033 [WARN ] [org.apache.felix.fileinstall        ] - Root path does not exist: /usr/share/openhab/addons
/openhab/userdata/backup/userdata-2022-06-28T16-58-50.tar:2022-06-28 16:51:39.030 [WARN ] [org.apache.felix.fileinstall        ] - /usr/share/openhab/addons does not exist, please create it.
/openhab/userdata/backup/userdata-2022-06-28T16-58-50.tar:2022-06-28 16:51:39.118 [WARN ] [org.apache.felix.fileinstall        ] - Root path does not exist: /usr/share/openhab/addons
/openhab/userdata/backup/userdata-2022-06-28T16-58-50.tar:felix.fileinstall.dir="/usr/share/openhab/addons"
/openhab/userdata/backup/userdata-2022-06-28T02-02-00.tar:2022-06-22 20:58:37.985 [WARN ] [org.apache.felix.fileinstall        ] - /usr/share/openhab/addons does not exist, please create it.
/openhab/userdata/backup/userdata-2022-06-28T02-02-00.tar:2022-06-22 20:58:38.027 [WARN ] [org.apache.felix.fileinstall        ] - Root path does not exist: /usr/share/openhab/addons
/openhab/userdata/backup/userdata-2022-06-28T02-02-00.tar:felix.fileinstall.dir="/usr/share/openhab/addons"
/openhab/userdata/config/org/apache/felix/fileinstall/cf1176bd-fd71-4575-9230-363630657842.config:felix.fileinstall.dir="/usr/share/openhab/addons"

Docker-Compose:

version: '2.2'
services:
  openhab:
    container_name: openhab
    #image: "openhab/openhab:latest-alpine"
    image: "openhab/openhab:3.2.0-alpine"
    restart: unless-stopped
    network_mode: host
    command: "bash -c 'if [ -e /openhab/restore/restore.zip ]; then echo y |/openhab/runtime/bin/restore /openhab/restore/restore.zip ; fi; exec tini -s ./start.sh server'"
    volumes:
      - "/etc/localtime:/etc/localtime:ro"
      - "/etc/timezone:/etc/timezone:ro"
      - "/mnt/tank/docker_volumes/openhab_addons:/openhab/addons"
      - "/mnt/tank/docker_volumes/openhab_conf:/openhab/conf"
      - "/mnt/tank/docker_volumes/openhab_userdata:/openhab/userdata"
      - "/mnt/tank/docker_volumes/openhab_restore:/openhab/restore"
      - "/mnt/tank/docker_volumes/openhab_backup:/openhab/backup"

It will probably stop complaining if you update this line to:

felix.fileinstall.dir="/openhab/addons"

1 Like

Seems like this was the solution.
Thanks a lot for helping me and for your awesome work in general!

1 Like

Great! :slight_smile: This is actually the same issue as the very first issue I ran into myself with openHAB. I ran OH by extracting the .zip, stopped it and renamed the dir where everything was extracted… restarted openHAB and everything stopped working. :frowning_face:

1 Like