Openhab Hue Emulation Not detected by Harmony hub

Hello there,
I just tried moving my openhab install from my Linux server to a raspberry pi 2
I started off with a clean install on an SD card, and installed the openhab cloud connector and the hue Emulation. I opened ports 1900 UDP and 80 tcp.

The harmony hub detects the hue bridge, but, although the pairing switch is triggered, the pairing does not succeed. I tried the tips from the documentation page of the hue emulation, but no luck either.
When the switch is flicked, I can see the bridge, but only on my PC, not with my phone.

Are there any suggestions what to do?

Also I would like to understand what is happening, when the pairing is happening.

I should also mention, that I had some bad luck with iptables before, but since I just reflashed the SD card, it worked flawlessly.

I just accessed the log files, and it says the following: Could not send UPNP response: Network is unreachable (sendto failed)
In addition to that, I found, that in this message, the IP looks more like an IPV6 adress, which is strange, as I use IPV4. (Using discovery ip fe80:0:0:0:5006:72cd:32e7:2b9a%eth0)

Also I did some more googleing, and the issue looks a lot like the one in this thread [SOLVED] [hueemulation] No Longer Able to Pair with Harmony Hub, but I am not able to access the selftest, so no chance to see if this works. Also, to my understanding, the issue causing this should be fixed in the latest build, which I am using.

So, I tried and tried and tried.
It seems like the HUE emulation has an issue with IPV6 beeing available, so I disabled IPV6 completely and reinstalled the HUE emulation and used the iptables forward mentioned in the docs. Now it works perfectly fine.
Any clue why this is?

1 Like

@javamaster10000 what do you mean IPV6 being available? Do you mean that the pi had both and IPV6 and IPV4 address?

Yep, it even had multiple IpV6 addresses. At least this is what my Fritz box reported. The ifconfig reported an IpV6 address and an ipv4 address.
I should also mention, that in paper ui, unser System, I set the ipv4 address as the address. I had also tried entering it manually as the HUE emulation address.

1 Like