openHAB installation on QNAP

Hi there,

I tried my first steps on openHAB with my Philips Hue, Logitech Harmony and Sonos devices.
The easy setup is working fine. Thanks for that!

Now I am struggling with the QNAP installation of openHAB in a different folder as explained (Creating a share called “openHAB2” or Creating a folder called “openHAB2” inside the “Public” share).
I don’t know how I can change the directories (addons, conf, userdata) or how this different installation works so that I can use Eclipse directly on a shared folder.

The only way I get openHAB running is the third one with the .qpkg file.

I would be nice if someone could help me with my problem.

Best regards,

I found a solution for myself.

I used the manual installation guide for Linux

  1. Create a shared folder “openHAB2” via the QNAP webinterface.

  2. Create a user (openhab) and group (openhab) in the QNAP webinterface.
    The “adduser” command ( adduser --system --no-create-home --group --disabled-login openhab) did not worked on the QNAP console.

  3. Add the user to the group and and give read/write access to the “openHAB2” folder via the webinterface.

  4. Login via putty SSH to the QNAP, and switch to the openHAB2 folder.

cd /share/openHAB2
  1. Download the latest snapshot release.

(btw. there is a wrong link for the release because of the actual version. I don’t know if it is possible to change the links automatically in the installation guide.)
You can find the right path if you go to:
<<<the hyperlink function isn’t working here>>>
Right click on the .zip file and copy the link.

<<<the line break also isn’t working here>>>

  1. Unzip the file.
unzip /share/openHAB2/ -d /share/openHAB2
  1. Change the owner of the openHAB2 folder.
chown -hR openhab:openhab /share/openHAB2
  1. Change the HTTP port of openHAB because you QNAP webinterface uses the same one.
vi /share/openHAB2/runtime/bin/setenv

search for


and change it to

  1. Start openHAB and go to the website: http://your-qnap-ip:8090. Enjoy!
/bin/bash -c '/share/openHAB2/' openhab

You can add a network share on your computer for the QNAP openHAB2 folder.

I have to say that I don’t know how I can start “my” openHAB2 installation as a service but I can edit and test the items/things/sitemaps etc. files directly, now.



folder needs to be called openHab (without the 2).
Documentation error…

See here:


1 Like

Thanks for this description,

My OpenHAB 2.2.0 snapshot starts … via shell and I seam to be able to use it.

Is there a way to get it start via GUI like the outdated 2.03 qnap version as well?

is there a release of openhab 2.2 qpkg ?

documentation is now updated for the problem of openHAB folder at installation

What does this mean ? - does a QPKG for openhab 2.2 now exist ?

no, only documentation for installation was updated. I’ll have a look about what needs to be done for a 2.2.0 update of the package

I’ve released a QPKG for openHAB 2.2.0 But the drawback is currently that you need to make a clean installation.
So if you are experienced with openHAB, you probably find an efficient way to update and could report it either here or in the github repo
QPKG releases

I use the Container Station of qnap qts 4.3.4 and installed openhab2 as a docker.
Pretty easy, just go to the settings inside the container, expand the advanced settings and eventually find the path to shared folder in the left menu. I use Visual Studio Code for editing the files.
have fun

1 Like

Any ideas on how to install ARPing for use with the network binding on a Qnap Docker installation? I can’t figure it out.

Thank you,