Openhab iOS app, iOS Shortcuts, iOS Home app - How to?

Woo, mind blown.

How does this thing work?
What I’m trying below doesn’t work.

*iOS Shortcuts app, accessing the OpenHab app, the one that connects to OpenHab Cloud for notifications.

what do you want to achieve exactly?

1 Like

Don’t know yet. I’ve just discovered this in iOS Shortcuts. But it looks like a powerful way to get my smart phone interacting with my smart home.

I just can’t make it do anything.
I think the procedure of updating my HomeKit bundle to latest snapshot, and installing the OpenHab 3 Milestone release has somehow broken my sitemaps and/or OpenHab iOS app (The one that sets up notifications and Cloud access) because nothing is showing here anymore.

I think the screenshot I showed above is the wrong way now.
I am now assuming that ithe “item” in blue should be clickable to show a list of items in the OpenHab app (sitemap items).

This is working for me…
Make sure your openhab app connects to your installation.
After that create a shortcut with the get item state.
Press and hold the item button. Select ask always. Now it will get all your item.
Now you can click on item an selcet the one you want to.

Really basic shortcut to turn a light on or off.

OK, I get to the first part now of choosing “Always Ask”, but when I click again I don’t see any items.

I only have a test sitemap for now, an On/Off switch and a dimmer. Both of these show in my iOS app now and control the items properly, so it is connected.

This is what I see after I have selected “Always Ask” then click again.

Sorry, forgot to say you have to start the shortcut with the play button.
Then it will “cache” the items and you can select one.
I had to do this only the first time, then all items where available to select.

Did it take long to cache? It’s been running for over 5 mins and it’s still spinning.
Does it take all items from openhab? Or just the sitemap?

I can select all itmes, not just the ones from Sitemap.

For me it took maybe 20sec to load the list.
Maybe try again.

Mine is just spinning forever. I’ve tried quitting the apps and restarting but can’t think of anything else to try.

Could it be something to do with this screen?
Should the Base URL be different?

Also, not sure if this is related, but I don’t see info here where I used to:

Checked mine, exactly the same. I exposed all items to myopenhab, base url is the same like yours (make sure it is the same in your openhab app) and the Info is also the same like your screenshot. Only App version is available and the rest got a - .

Please don’t expose any Item unless there is a real need for it (like it was for IFTTT), this produces unneeded/unwanted load on our servers.

Alexa or Google Assistant work with proper tagging, no need to expose.

Even the IOS Shortcut App will find unexposed Items, as it does a REST API request through openHAB APP.

So I should have no exposed items and I should still see items in my iOS Shortcuts app?

I’m still stuck trying to get past the step of running the Get State for the first time to cache.

My url in my app is as I was directed by the installation process. Neither changing my Main UI to match my phone or changing my phone to match my Main UI worked.

I have 408 items in OpenHab

Exactly !

First try to setup your shourtcut through local connection, the we can test remote functionality.

Good to know! Thought I need to expose them to get access to them.
Will uncheck the exposing :+1:

I don’t know what I’ve done. But in the process of changing these urls in my app and Main UI, now says that my openhab is offline.

How can I start to fix this now?

I can still send notifications to my device from
My UUID and Secret are still correct.

EDIT: OK seem to have got this back to ‘online’ now.

First try to setup your shourtcut through local connection, the we can test remote functionality.

How can I do this?
Whenever I remove the Remote URL my sitemap diasappears and the field is auto filled with “