openHAB Milestone builds

Same here, no problems with M2. Using fritz, chromecast, elero, neato, openweather, sonos, systeminfo, trädfri, zway.

Vetted MyQ, sonos and ambient weather, systeminfo. Still struggling with the Samsung TV binding. Chipping away here. Thanks again to all. Ya’ll are an amazing group of people!:clap:

1 Like

After update on M2 I get the following error message:

2019-08-10 19:35:59.118 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-misc-restdocs's

Besides, my Zigbee things are not going online
What can I do?

That Zigbee things keep offline happened to me when I updated the binding. I just had to reset the devices and rejoin them and then everything worked flawlessly

Hi, about the rest API. It has been moved from misc to UI

[openHAB] Listing important changes for version 2.5.0:
  Warning:  senseBox Binding: The senseBox binding is now using Units of Measurements, and the channel name for Illuminance has changed. The Items must be reconfigured.
  Warning:  Vitotronic Binding: The following channels have been renamed: 'outsite_temp' to 'outside_temp', 'pelletburner:power' to 'pelletburner:powerlevel', 'party_temp' to 'party_temp_setpoint' and 'save_temp' to 'save_temp_setpoint'
  Warning:  OneWire Binding: Some thing types have changed and need to be updated in textual configurations. See documentation for further information.
  Warning:  REST Docs: This add-on is now part of the UIs. When installing it using textual configuration, update 'services/addons.cfg' by removing 'restdocs' from 'misc' and add it to 'ui' instead.
  Warning:  EnOcean Binding: Channel 'receivingState' has been removed, because this was a string containing many information. For this, there are three new channels: 'rssi', 'repeatCount' and 'lastReceived'.
  Warning:  Mail Action: The mail action has been replaced by a new mail binding.
  Warning:  Homekit: Some tags have been renamed. Old names will not be supported in future versions. Please check documentation.
  Warning:  Pushbullet Action: The pushbullet action has been replaced by a new pushbullet binding.
  Warning:  DarkSky Binding: The item type of `rain` and `snow` channels have been changed to `Number:Speed`.
1 Like

Fix it the same place I fixed my problem ;

I updated all of the UI jar files from the Jenkins link. Now I can’t connect to my OH server. I never shut down fronttail and it is still running on my windows7 laptop. 0 error’s show up through the fronttail log. I have an ipad still connected to paper UI and if I try to refresh that it gives me a “Error 503 - Jersey not ready yet”. In addition prior to my reboot, but after installing all of the M2 UI’s everything on my OH welcome screen was duplicated. I suppose I could go in and remove all of the freshly added M2 UI’s but I would rather not. I would much prefer to keep the updated ones and remove the M1 UI’s. Can anyone with a much bigger brain then mine provide me with a suggestion? I did not import any M2 persistence files. Is this possibly where I went wrong? Also I can still connect to my openhabianpi from VSC. Thanks in advance for any help provided. We are Openhab Strong :muscle:

in my addons.cfg there is no such ENTIRE

Hi @ollis112

Did you install the rest API thru the UI? (I haven’t used the UI for along time) :wink:

Maybe you can find it it somewhere here?

/var/lib/openhab2/config/org/openhab/addons.config
/etc/openhab2/services/runtime.cfg
/etc/openhab2/services/addons.cfg
1 Like

A comma-separated list of miscellaneous services to install (e.g. “misc = myopenhab”)

#misc =

all entries are preceded by a “#”

Ok, what about the other files?

Else you may habe better luck fixing it with openhab-cli

You can get list of installed bundles with bundle:list | grep -i rest

Here are my list from my M1 installation

openhab> bundle:list | grep -i rest                                                                                                                               
119 │ Active   │  80 │ 0.11.0.oh250M1         │ Eclipse SmartHome REST Interface Bundle
120 │ Active   │  80 │ 0.11.0.oh250M1         │ Eclipse SmartHome Core REST API
121 │ Active   │  80 │ 0.11.0.oh250M1         │ Eclipse SmartHome REST mDNS Announcer
122 │ Active   │  80 │ 0.11.0.oh250M1         │ Eclipse SmartHome REST Interface JAX-RS optimization Bundle
123 │ Active   │  80 │ 0.11.0.oh250M1         │ Eclipse SmartHome Sitemap REST API
124 │ Resolved │  80 │ 0.11.0.oh250M1         │ Eclipse SmartHome SSE REST API
125 │ Active   │  80 │ 0.11.0.oh250M1         │ Eclipse SmartHome Voice REST API
243 │ Active   │  80 │ 2.5.0.M1               │ openHAB REST Documentation

And from my M2 installation:

openhab> bundle:list | grep -i rest
151 │ Active  │  80 │ 2.5.0.M2              │ openHAB Core :: Bundles :: REST Interface
152 │ Active  │  80 │ 2.5.0.M2              │ openHAB Core :: Bundles :: REST Interface :: Core
153 │ Active  │  80 │ 2.5.0.M2              │ openHAB Core :: Bundles :: REST mDNS Announcer
154 │ Active  │  80 │ 2.5.0.M2              │ openHAB Core :: Bundles :: REST JAX-RS Optimizations
155 │ Active  │  80 │ 2.5.0.M2              │ openHAB Core :: Bundles :: Sitemap REST Interface
157 │ Active  │  80 │ 2.5.0.M2              │ openHAB Core :: Bundles :: Voice REST Interface
281 │ Active  │  80 │ 2.5.0.M2              │ openHAB UI :: Bundles :: openHAB REST API Documentation

You could try to uninstall it with

bundle:uninstall <ID>

My List is the same like your list
And now??

I’m sure there are something some where that has not been cleaned up.

Did you try to clear your cache?

I made a script to make it easy here: My point of view of Openhab2, stability and a few good to know stuff

Have you checked in
userdata/config/org/openhab/addons.config ?

My Cache is clear

Ok, could you post the content of the 3 files: ?

/var/lib/openhab2/config/org/openhab/addons.config
/etc/openhab2/services/runtime.cfg
/etc/openhab2/services/addons.cfg

I had also installed the rest docs via paperui and had the same error message. You need to edit userdata/config/org/openhab/addons.config, as others have said, and remove restdocs from the misc=-line.
Then you can reinstall it through paperui.

Hi :slight_smile:

I made a sum up of my findings here: My point of view of Openhab2, stability and a few good to know stuff

Thank you first for your help. But after my system had crashed completely, I have to set it up anew.
Here is a question:
Can I restore the backup from 2.5M1 to M2?
If not, where can I get the M1 version to import the backup?
Many thanks

Hi @ollis112

You are welcome. Happy to help :slight_smile:

You should be able to download 2.5M1 at the old repo by hand here: https://dl.bintray.com/openhab/apt-repo2/pool/main/2.5.0~M1/

1 Like