OpenHAB not applying changes made to config

Hello community,

I am currently running OpenHAB 2.5.2 in a docker container. Had it running like this without an issue for the laste 50+ days. Now I wanted to make changes to the config and that’s when I ran into my issue.
If I remove/ add anything in the config files, those changes won’t be applied.
Example: I removed a couple of lines in my .sitemap, but those lines I just removed are still visible in the sitemap across all devices. Same goes with adding lines to the sitemap, but the changes are nowhere to be seen.
What I tried so far:

  • Updating container
  • Checking Read/Write permissions
  • Restarting container
  • Deleting tmp and cache directory of openhab

Please keep in mind the config files have been migrated from an bear metal install to a docker instance.

I hope someone can help me with this issue.


What is your Docker volume mapping? A volume mapping error could have openHAB looking elsewhere for the configuration.

version: '2.2'

    image: "openhab/openhab:2.5.2"
    restart: always
    network_mode: host
    container_name: openhab
      - "/etc/localtime:/etc/localtime:ro"
      - "/etc/timezone:/etc/timezone:ro"
      - "./openhab_addons:/openhab/addons"
      - "./openhab_conf:/openhab/conf"
      - "./openhab_userdata:/openhab/userdata"
      OPENHAB_HTTP_PORT: "8080"
      OPENHAB_HTTPS_PORT: "8443"
      USER_ID: "111"
      GROUP_ID: "113"
      CRYPTO_POLICY: "unlimited"
      EXTRA_JAVA_OPTS: "-Duser.timezone=Europe/Berlin"

This is my docker compose file

You have folders /openhab/addons, openhab/conf, and /openhab/userdata created on your machine and owned my user ID 111. Correct? I would also be sure the /openhab folder is owned by that user too, and all the files too

sudo chown -R 111:113 /openhab should make sure. At least I think you can use UID & GID with chown

Output of ls -al

drwxr-xr-x 6 openhab openhab 4096 Mar 19 20:44 openhab <— OH root directory, which contains the other three

drwxr-xr-x 2 openhab openhab 4096 Jan 28 15:23 openhab_addons

drwxr-xr-x 13 openhab openhab 4096 Jan 12 21:35 openhab_conf

drwxr-xr-x 9 openhab openhab 4096 Mar 19 18:12 openhab_userdata

you have wrong folders mapped
you need to specify full path, no relative to anything

do it like that: (or whatever, but specify full path!)

        -v /opt/openhab/conf:/openhab/conf \
        -v /opt/openhab/userdata:/openhab/userdata \
        -v /opt/openhab/addons:/openhab/addons\

The issue still persists. Weird enough, like I said before, the config inside the container shows the changes, but those changes are not reflected in the sitemap or paperui

That is WRONG. Did you mean

      - "/etc/localtime:/etc/localtime:ro"
      - "/etc/timezone:/etc/timezone:ro"
      - "/openhab_addons:/openhab/addons"
      - "/openhab_conf:/openhab/conf"
      - "/openhab_userdata:/openhab/userdata"

You have extra . at the beginning of some volumes.

Figured it out…my bare metal install was still running so docker openhab did not work. My compose file btw is right and works.

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.