openHAB not authorized to access Hue bridge (SOLVED)

Solved: Did some searching and found an update on github. Taught myself how to compile from source and fixed it

Installed openhab today utilizing the makeuseof tutorial.

Step by step using hue as my first binding. I added the correct IP and uncommented in the openhab.cfg and also did it in the openhab_default.cfg just in case as I was not sure which one to edit.


log file just keeps repeating this…

2016-04-29 03:55:57.789 [WARN ] [inding.hue.internal.HueBinding] - openHAB not authorized to access Hue bridge

Am I the only one with issues?

Could it be something with the firmware update for the Hue that was pushed recently?

How were you able to compile? Having the same issue…

Got it, saw this thread which was helpful: How to build a specific binding with Maven

Not sure if this is germane or not. I just yesterday started to install openHAB and ran into the pairing issue.

Philips recently pushed out a new update which may have changed a new user registration method.


which notes:
“Currently it is possible to create your own usernames in the bridge (e.g. “newdeveloper”), however, this option will be removed in future bridge versions, so we need to use the randomly generated username that the bridge creates for you.”

Suspecting that the “secret word” used in the .cfg. file and the Hue username are supposed to match, and guessing that since the update that the Hue bridge has to issue the random username, I followed the example on the getting started page, creating a new user using the API tool. That issued a 20-digit or so user ID which I pasted back as the “secret word” in the config file.

And, it looks like that got things going. I had previously tried changing the “secret word” to something else, something longer than 10 characters, recommended elsewhere, but that didn’t work for me.

1 Like

This is addressed with

1 Like

When can I get this fix in the deb stable main ? In 1.8.3 or even before? When will there be a 1.8.3 update?

Today, there was another firmware update for Philips Hue and - a coincidence? - also an update of OpenHab 1.8.3. Just tested the authorization with the new firmware. Still or again not working…

Any updates? I just got a hue and I can’t get it to work with openhab.

The PR has not been included in the 1.8.3 release. See comments thread in:

sorry to reply to that old thread.
I bought a hue bridge yesterday. During startup it updated to recent firmware and with OpenHAB 1.8.1 and 1.8.3 bindings I was not able to connect to Hue via described methods.
My solution was following:

go to hue API debugger and create a new user
take the user and maintain it into the openhab.cfg
I also specified the IP of the hue bridge (in openhab.cfg)
started openhab, pressed the hue button

Best Regards,

You do that by opening
fill URL with /api
fill MessageBody with something like {"devicetype": "openhabHueBinding#openhab"}
press hue box button
click POST
find username in response.

1 Like

How do you add the username to the config file?

Nevermind, I got the pairing working by using username:password format.

I am still having an issue. Can you please post the exact format you used for hue:secret=?

OK - got it to work. It may be obvious to some, but the helpful information here still needed some decoding by mere mortals (aka low-tec users).

This response from sna_dro provides exactly what is needed to get paired:

but what is not obvious is:

When you browse to your bridge IP address with /debug/clip.html you get a response inviting you to post a command.

Fill in the fields as listed above, press the hue button, click POST and you get back some text.
Within the text is a string of characters after “username”, copy them into your openhab.cfg as the “secret”, restart the openhab service, and you are connected!