OpenHab not getting data from z-wave devices

Tags: #<Tag:0x00007f2fb5870bb8>

I just made a Factory Reset of my Aeotec z-stick gen5 and paired the power switch. Now it is working as expected.

Now I have to pair all other devices and start all over…

This reset the configuration parameters to the device’s defaults.

:man_shrugging:

If you made one, you can restore your stick from backup.

Damn, now my Fibaro Dimmer 2 does not behave…

The Electric Meter (watts) is not updated correctly. When I change the dimmer I sometimes get a new value for the power (watts) but it looks like the value is from the previous setting. And sometimes it does not update at all. Right now the dimmer is turned to 0% (off) but the power is showing 18 watts and stays there.

Im getting tired…

Regarding associations, I have tried setting all groups to Controller. I also tried setting only the first group to Controller (and the first and the second, and the first and the second and the third etc…).

Regarding other settings, I tried quite a lot of combinations. I have sent a screen dump but I tries a whole lot of other combinations.

By the way, the current tests are made on a new computer, a new Openhab installation. I only added one thing, the Fibaro dimmer and two items (Dimmer and Electric meter watts). Tried both Paper UI and Habmin, but it is the same issue.

Thanks @rossko57, I have now set the deprecated flag to help choosing the correct channels.

Thanks, Power1 is working!!

But where did you get the screen dump above?

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list

Dear all.

Thank you very much for your help! Its really appreciated!!

Unfortunately I got a new (old) problem with one of my “Fibaro Dimmer 2” 's. When I operate the dimmer using the switch on the dimmer, this information is not sent to Openhab. The firmware version is different from the ones working. This one has firmware version 3.4 (not working). The rest has version 3.5 (working). All setting looks identical. I tried mapping all channels but no luck. I also set the Lifeline to the controller.

Double check your association group. Don’t associate any other groups except Lifeline.
If it still does not work please provide a debug log.

I enabled debugging, turned on the dimmer (using the switch on the dimmer) and turned it off after 20 seconds. OpenhabDebugLog.txt (241.2 KB)

Which node number?

grafik

its node 6

And where did you get this screen dump from? :slight_smile:

https://www.cd-jackson.com/index.php/openhab/zwave-log-viewer

Thanks, i’m still learning…

What did the log tell you?

Sorry, have been out of town.

Which channels are you watching for state changes? Looks like that are the wrong ones, you need to use the channels for endpoint 1:

Switch FibFGD212_1_Sw (gRestore) { channel="zwave:device:uzb:node37:switch_dimmer1", autoupdate="false" }
Dimmer FibFGD212_1_Dim (gRestore) { channel="zwave:device:uzb:node37:switch_dimmer1", autoupdate="false" }

I have that channel mapped:

You are missing the state updates for the switch_dimmer1 channel.
Make sure you are setting the association through HABmin, not PaperUI: