Openhab not logging after upgrade to 1.8.1


I just upgraded (apt-get) from 1.8.0 to 1.8.1 and there are no logs (openhab.log nor events.log) being written anymore. Openhab is working though…

Any ideas?

Anything unexpected about the ownership and permissions of /var/log/openhab, the existing files there, or parent directories? Does the user that’s running the openHAB server have needed permissions/ownership?

Everything normal, openhab user owns them with all privileges and same user runs openhab.

I didn’t have logging problems specifically but was having what I think were permissions problems On Raspbery Pi.

I finally rebuilt from scratch and things are good now.
I should have rebuilt right away which only took a couple of hours versus the 10 hours or so trying to fix the old install.

I know that doesn’t help at all with your current installation.

I guess I’ll end up having to do that too :frowning:

SOLVED, I edited /etc/init.d/openhab and removed --background , restarted openhab, re-edited the file including --background again and logging is back to normal. Weird stuff

I thought it was solved but it turns out that only when DEBUG=yes in /etc/default/openhab do I get logs to be written…

Just adding a me too on this. Logging appeared to be working but now its stopped and I can’t see why its failed. followed the suggestions from federic0 but no joy. Might just do a reinstall as I’ve only just started playing. I’ll update if I figure anything out