OpenHab not upgrading from 4.0.1 to 4.1


i’m unable to update to 4.1

i’ve tried this using openhabian-config
@Oliver2 here’s the output you asked for:

Get:1 bullseye InRelease [15.0 kB]
Hit:2 bullseye InRelease
Get:3 bullseye InRelease [4,586 B]
Hit:4 comitup InRelease
Fetched 19.6 kB in 1s (22.1 kB/s)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
Listing... Done
raspinfo/oldstable 20230123-1 all [upgradable from: 20221220-1]
raspinfo/now 20221220-1 all [installed,upgradable to: 20230123-1]

ok. Now it is clear. Openhab apt source is missing.
Please check, if the following file exist:


content of openhab.list

deb [signed-by=/usr/share/keyrings/openhab.gpg] stable main

You probably need to change the directory where openhabian stores the keys.

1 Like

@Oliver2 the file existed but was empty. i added the text you gave and the upgrade worked just fine, I’m now running 4.1.1, thanks

I haven’t changed the location of the keys, if the upgrade worked, is it safe to assume there’s no further problem?


I don‘t see any other problems at least for openhab updates.

1 Like