openHAB on Beagle bone black

Try to get openHAB running on Beagle Bone black. It boots but than errors pop up.
Guess it is not running, as Java 8 is latest for 32bit system, right and it needs Java11?

Does it worth do start with openHAB 2.5.12?
I would like to log Smartmeter, Heatpump and Solar Converter (HTML).

I have no experience with the beagle bone but what I can say is that I am running 3.4.1 on a RPI4 with openhabian which AFAIK is based on debian 10 and it is running java 11.

I would advice against openHAB 2.5.x as it is pretty old and will not get any support. 3.4.x is stable and 4.x will come soon.

What is the error message that you get ? Without a bit more details answer are more likely guesses.
Zulu 11 is available for 32 bit systems.

yepp, PI has a 64 bit processor that is capable of running that.
And yes, I installed zulu11 now and get one step further.

System is a Debian GNU/Linux 10 Debian Buster IoT Image 2020-04-06

It launches to openhab, but I don’t get the openhab website to be seen. There seems to be an nginx server running, maybe that interferes.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Feb 18 10:33:11 2023 from
Launching the openHAB runtime…
Listening for transport dt_socket at address: 5005

                       _   _     _     ____  

___ ___ ___ ___ | | | | / \ | __ )
/ _ \ / _ \ / _ \ / _ \ | || | / _ \ | _ \
| (
) | () | __/| | | || _ | / ___ \ | |) )
___/| / _/|| |||| ||// _|__/
| 3.4.2 - Release Build

Use ‘’ for a list of available commands
and ‘[cmd] --help’ for help on a specific command.
To exit, use ‘’ or ‘logout’.

Returns a welcome to nginx

If I stop nginx (“sudo systemctl stop nginx”) before starting openHAB than there is no web-page at all to be seen.

debian@beaglebone:~/openhab$ cat userdata/logs/openhab.log
2023-02-18 10:56:59.984 [INFO ] [.core.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2023-02-18 10:57:07.270 [INFO ] [e.automation.internal.RuleEngineImpl] - Rule engine started.
2023-02-18 10:57:39.797 [INFO ] [ab.ui.habpanel.internal.HABPanelTile] - Started HABPanel at /habpanel

If I call port 5005 than I get a bunch of errors:
openhab> Debugger failed to attach: handshake failed - received >GET / HTTP/1.1< - expected >JDWP-Handshake<
Debugger failed to attach: handshake failed - received >GET / HTTP/1.1< - expected >JDWP-Handshake<

But I don’t know what exactly doesn 5005 and this errors mean. Some outdated protocol?


Seems I just need to bit more patient. Get the openHAB website now. But the nginx needs to be stopped.

Thanks for the hint with zulu!

you may configure nginx or openhab to run on a different port.

How did you install openHAB and why is there an nginx?

I am running openhabian and this is what my ports are listening to:

sudo lsof -i -P -n | grep LISTEN | grep openhab

java        764    openhab   85u  IPv6    27243      0t0  TCP *:8443 (LISTEN)
java        764    openhab  131u  IPv6    24963      0t0  TCP (LISTEN)
java        764    openhab  151u  IPv6    26191      0t0  TCP (LISTEN)
java        764    openhab  172u  IPv6    27246      0t0  TCP *:8080 (LISTEN)
java        764    openhab  191u  IPv6    29502      0t0  TCP *:5007 (LISTEN)

That’s not a PI it’s a Beagle bone black - completly different boards and different images.
@Wolfgang_S : need to check how to reconfigure that. No experience with nginx.

Check the content of the folder /etc/nginx and its sub folders.
Search for 8080. As long as you are unsure what you do make a backup of the current file.

I am aware of that but I wanted to give you some help in regards with the setup :man_shrugging:

It is important not to be to impationed. Especially until java creates the initial webpage on such a small processor as in Beagle … that takes some minutes.

I’m not so familiar with system d, but think I could avoid starting it by rename
My attempts to disable it in rcx.d … failed.

8080 occures in
/etc/nginx/sites-available/default: listen 8080 default_server;
/etc/nginx/sites-available/default: listen [::]:8080 default_server;
/etc/nginx/sites-enabled/default: listen 8080 default_server;
/etc/nginx/sites-enabled/default: listen [::]:8080 default_server;

I have some first success, could add bindings, things and items - but what is hard to understand is how to create the pages itself. Need more time for socu to read.

Should be these entries:

sudo systemctl stop nginx
sudo systemctl disable nginx