Openhab on Raspberry PI 5

I got my first RBPI5 (8GB) today, and sure wanted to install an OpenHab immediately. However, I found that the Raspberry Pi Imager (v1.8.1) does not yet include an option for OpenHab when selecting Raspberry Pi 5. And when using an RBPI4 device so that I can select Openhab as OS, the device does not start but shows an “OS not supported” error directly when booting up.

Any idea when the Imager will support OpenHab on a RBPI5?

See here

In the mean time you can try one of the following.

  1. Install a stock bookworm lite Raspberry Pi OS and see is the manual installation instructions for openHABian work.

  2. Install a stock bookworm lite Raspberry Pi OS and install OH using apt following the instructions on the Linux Installation page or the Downloads page (see above).

Lucky guy - still waiting for German resellers to get them in stock… :smiling_face_with_tear::+1:


try this Raspberry Pi 5 "S-Bundle" 8GB RAM weiß | SW12086

1 Like

Oh nice - that worked :star_struck:

I did sign up to get notified with some other resellers - but there I’m still waiting :sweat_smile:


When you and anyone in the community will have provided sufficient help in testing and getting this to work.

See also here.

Start helping by trying the beta release of openHABian and provide qualified feedback i.e. any first-boot.log and proper description that might help with pinpointing the issues I encounter.

My openhab installation is running on a raspberry pi 4 with ubuntu and docker. For me it was the easiest way…

Install on your pi5 the newest lite os bookworm.
After that you should be able to install docker.
How to Install Docker on Raspberry Pi: A Step-by-Step Guide (

# download and install docker
curl -sSL | sudo sh
# give your current user to interact with docker
sudo usermod -aG docker ${USER}
# login and logout again
docker pull openhab/openhab

Next step you could start your openhab session with the simple command ( openhab/openhab - Docker Image | Docker Hub)

docker run \
  --name openhab \
  --net=host \
  -v /etc/localtime:/etc/localtime:ro \
  -v /etc/timezone:/etc/timezone:ro \
  -v openhab_addons:/openhab/addons \
  -v openhab_conf:/openhab/conf \
  -v openhab_userdata:/openhab/userdata \
  -e "CRYPTO_POLICY=unlimited" \
  -e "EXTRA_JAVA_OPTS=-Duser.timezone=Europe/Berlin" \
  -d \
  --restart=always \

Have fun

thanks - that worked perfect!

I would like to offer the boot.log.
You meantioned using 1.9 beta image, but I can not find it. Your link is unfortunatelly not working. Can you tell me which version (link) I should try?

Also happy to help here. But as @wlanrouter1 mentioned, the link provided leads to a 404

1 Like

Did a first install with the provided image “openhabian-pi-raspios32-202310310839-git737aa94-crc33517e1f.img.xz” on Raspi 5
Worked fine, OS was installed and OpenHab 4 is up and running. I haven’t restored my OpenHab config, yet.
There were some error visible with

journalctl -p err

but I can’t say if they have to be regarded as serious.

first-boot.log (286.3 KB)
journalctl.txt (1.1 KB)

Same here. As the hardware is the same, I assume you don’t need the log files a second time. But I can not setup up WiFi over openHabian Configuration Tool.

Going to Menu “37 | WiFi setup” leads to the message “We could not detect any WiFi hardware on your system…”
But I have the option to continue nevertheless to let OpenHabian try it. Scanning seems to work, I found all networks. Choosing the SSID, entering passwort, choosing Country Code (tried US and DE) leads to:
“There was an error or interruption during the execution of
30 | System Settings”

I can fix it manually, but maybe you are interested in this issue? Is there anything I can share with you?

Btw. I also can not install “26 | Homegear” over openhabian config tool. Same error message as WiFi. But I assume an issue with homegear apt package as this project is most likely not bookworm ready.

I don’t think so. Could you try 64bit, too, please ?

There was no HW check for Pi5, I’ve added it.
Please update openHABian on tool start (use main branch) and try “source /opt/openhabian/functions/helpers.bash; is_pi5 && echo 5” to see if the check is ok
Then try again with wifi.

Is it ok that the compressed 64 Bit image ist so much smaller than the 32 Bit one?

What do you mean by tool start (use main branch)?
I went to

sudo openhabian-config

and chose “02 | upgrade system”
Afterwards I run

source /opt/openhabian/functions/helpers.bash; is_pi5 && echo 5”


sudo source /opt/openhabian/functions/helpers.bash; is_pi5 && echo 5”

Output was “bash: is_pi5: Kommando nicht gefunden.”

Tried Wifi Setup again, same issue. What should I do or what did I wrong?

Regarding homegear:
Tried it through apt. I made no changes on my own since flashing and I will not change the sources on my own for helping you. (I assume by your name that you speak German, otherwise I can translate it.)

[08:53:29] root@openhabian:/home/openhabian# apt update
OK:1 bookworm InRelease
OK:2 comitup InRelease
OK:3 bookworm InRelease
Ign:4 bookworm InRelease
OK:5 bookworm InRelease
Fehl:6 bookworm Release
  404  Not Found [IP: 443]
Fehl:2 comitup InRelease
  Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 0959C4A3DCF89FBF
OK:7 stable InRelease
Paketlisten werden gelesen… Fertig
W: Schlüssel ist im veralteten Schlüsselbund trusted.gpg gespeichert (/etc/apt/trusted.gpg), siehe den Abschnitt MISSBILLIGUNG in apt-key(8) für Details.
E: Das Depot » bookworm Release« enthält keine Release-Datei.
N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).
W: Während der Überprüfung der Signatur trat ein Fehler auf. Das Depot wurde nicht aktualisiert und die vorherigen Indexdateien werden verwendet. GPG-Fehler: comitup InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 0959C4A3DCF89FBF
[08:53:36] root@openhabian:/home/openhabian# apt install homegear
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
E: Paket homegear kann nicht gefunden werden.

Additional issue:

sudo openhabian-config

and choosing “34 | change passwords” has no effect for “Linux System” and “Samba”. Passwort stays the same “openhabian” even after reboot. Have not tested “openHab console” or “Amanda backup” password.
I noticed that after changing Password, this is the output:

on start the tool asks you if to update
Then use option 01 to select main branch if you don’t use it yet

I am not quite sure what you mean by tool. openhabian-config?

It is not asking me to update on start. Version informations (Stop displaying/keep displaying) is coming up and afterwards I am straight in the main menu. Do I need to flash it again?