openHAB on Raspberry Pi does not accept my commands via karaf

Good day folks,

today I came across a very weird problem while trying to give commands to my rasp pi through karaf.
I tried to give the command:
openhab:homekit clearPairings

but every time i get the same error message
-bash: openhab:homekit: command not found

In the console it just looks like this:

I need to clear my pairings because the homekit integration does not allow any new pairings.
I know the homekit command line changed from “smarthome:homekit” to “openhab:homekit”, but none of these work, i receive the same message again and again. Even deleting the Homekit integration via UI does not clear any pairings.
I hope someone knows this problem :),


It looks like you’re not actually in karaf. The command prompt and bash error seem to indicate that you’re just in the pi’s bash console and haven’t actually opened karaf.

1 Like

Yeah, you´re right.

I wasn´t fully connected to openHAB, just the openhabian process on my rasp.
Thanks :slight_smile: