Openhab/openhab docker fail

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
    • OS: what OS is used and which version
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:
    I, as many OH users regularly destroy my files and crash my system due to testing and playing and learning.
    I have tried to pull/run docker openhab/openhab many times, it gets to “Launching openhab runtime:” and ends.
    I have followed the docs by the letter and read the docs repeatedly to see if I have done something wrong.
    I have used the docker provided “Hello-World” after each docker install with success.
    Where do I go from here?
    Any help would be greatly appreciated.


Start by providing the information asked in the template you copied.

RaspberryPi 3b+
Ip =

Release = Raspbian GNU/Linux 10 (buster)

Kernel = Linux 4.19.66-v7+

Platform = Raspberry Pi 3 Model B Plus Rev 1.3

Uptime = 0 day(s). 0:1:55

CPU Usage = 1.5% avg over 4 cpu(s) (4 core(s) x 1 socket(s))

CPU Load = 1m: 0.46, 5m: 0.28, 15m: 0.11

Memory = Free: 0.59GB (63%), Used: 0.35GB (37%), Total: 0.95GB

Swap = Free: 0.09GB (100%), Used: 0.00GB (0%), Total: 0.09GB

Root = Free: 53.06GB (94%), Used: 2.84GB (6%), Total: 58.30GB

Updates = 0 apt updates available.

Sessions = 1 session(s)

Processes = 126 running processes of 32768 maximum processes


          Welcome to            __  _____    ____  _
        ____  ____  ___  ____  / / / /   |  / __ )(_)___ _____
       / __ \/ __ \/ _ \/ __ \/ /_/ / /| | / __  / / __ `/ __ \
      / /_/ / /_/ /  __/ / / / __  / ___ |/ /_/ / / /_/ / / / /
      \____/ .___/\___/_/ /_/_/ /_/_/  |_/_____/_/\__,_/_/ /_/
              openHAB 2.5.0~M3-1 (Milestone Build)

[07:59:17] openhabian@openhab:~$ sudo docker run openhab/openhab
Unable to find image ‘openhab/openhab:latest’ locally
latest: Pulling from openhab/openhab
3f5b615a5b21: Pull complete
6648b8a6a5f7: Pull complete
a45e1abbc726: Pull complete
4955643a125d: Pull complete
f77195ea6246: Pull complete
28b6ea08a3a9: Pull complete
cdf79932caef: Pull complete
Digest: sha256:c41f2f50cbb25c23bf78b39a158a43fe8c2c1da9f0a36a27878125ef34a40247
Status: Downloaded newer image for openhab/openhab:latest
++ test -t 0
++ echo false

  • interactive=false
  • set -euo pipefail
  • IFS=’
  • ‘[’ limited = unlimited ‘]’
  • rm -f /openhab/runtime/instances/
  • rm -f /openhab/userdata/tmp/instances/
  • NEW_USER_ID=9001
  • NEW_GROUP_ID=9001
  • echo ‘Starting with openhab user id: 9001 and group id: 9001’
    Starting with openhab user id: 9001 and group id: 9001
  • id -u openhab
    ++ getent group 9001
  • ‘[’ -z ‘’ ‘]’
    Create group openhab with id 9001
  • echo ‘Create group openhab with id 9001’
  • groupadd -g 9001 openhab
    Create user openhab with id 9001
  • echo ‘Create user openhab with id 9001’
  • adduser -u 9001 --disabled-password --gecos ‘’ --home /openhab --gid 9001 openhab
    Warning: The home dir /openhab you specified already exists.
    Adding user openhab' ... Adding new useropenhab’ (9001) with group openhab' ... adduser: Warning: The home directory/openhab’ does not belong to the user you are currently creating.
    The home directory /openhab' already exists. Not copying from/etc/skel’.
  • groupadd -g 14 uucp2
  • groupadd -g 16 dialout2
  • groupadd -g 18 dialout3
  • groupadd -g 32 uucp3
  • groupadd -g 997 gpio
  • adduser openhab dialout
    Adding user openhab' to groupdialout’ …
    Adding user openhab to group dialout
  • adduser openhab uucp
    Adding user openhab' to groupuucp’ …
    Adding user openhab to group uucp
  • adduser openhab uucp2
    Adding user openhab' to groupuucp2’ …
    Adding user openhab to group uucp2
  • adduser openhab dialout2
    Adding user openhab' to groupdialout2’ …
    Adding user openhab to group dialout2
  • adduser openhab dialout3
    Adding user openhab' to groupdialout3’ …
    Adding user openhab to group dialout3
  • adduser openhab uucp3
    Adding user openhab' to groupuucp3’ …
    Adding user openhab to group uucp3
  • adduser openhab gpio
    Adding user openhab' to groupgpio’ …
    Adding user openhab to group gpio
  • case ${OPENHAB_VERSION} in
  • initialize_volume /openhab/conf /openhab/dist/conf
  • volume=/openhab/conf
  • source=/openhab/dist/conf
    ++ ls -A /openhab/conf
  • ‘[’ -z ‘html
    transform’ ‘]’
  • initialize_volume /openhab/userdata /openhab/dist/userdata
  • volume=/openhab/userdata
  • source=/openhab/dist/userdata
    ++ ls -A /openhab/userdata
  • ‘[’ -z ‘etc
    tmp’ ‘]’
    ++ cmp /openhab/userdata/etc/ /openhab/dist/userdata/etc/
  • ‘[’ ‘!’ -z ‘]’
  • chown -R openhab:openhab /openhab
  • sync
  • ‘[’ -d /etc/cont-init.d ‘]’
  • sync
  • ‘[’ false == false ‘]’
    ++ IFS=’ ’
    ++ echo gosu openhab tini -s ./
  • ‘[’ ‘gosu openhab tini -s ./’ == ‘gosu openhab tini -s ./’ ‘]’
  • command=($@ server)
  • exec gosu openhab tini -s ./ server
    Launching the openHAB runtime…

nothing shows up in the logs

and thank you @Bruce_Osborne for your fast response. you Rock!

I’m sorry Bruce,
Its my first time posting a new topic.
I am sorry it had to be posted one more time.
I have never seen that thread and did not relate code fencing and my post.
but I have it up and am reading through it now.
Thank you again

BTW, I did not post any coding.
I copied from the docker run command from putty and the docker distro process and pasted it to where it locks up.

Code fences make configuration and logs more readable. Most people will not look at a long wall of text like you posted.
Code fences also keep spacing, which is important in configuration.

I can understand that.
maybe docker is just not in my openhab future. LOL
your the best my friend.
Always grateful to you for helping so many of us noobs.

Has anyone ever used docker pull/run openhab/openhab successfully?

You mean pulling an image from docker hub? Trying to understand what docker pull/run means.

I mean I have no problem pulling the docker container openhab/openhab.
I have no success docker run openhab/openhab.
Sorry again for the lack of clarity

It won’t expose a port for you to connect this way. Try adding --net=host like in the documentation:

I am a docker newbie and have not used it much. No need to apologize.

As wborn points out, you are missing a ton of command line arguments to the docker run command. You need to set up the networking (–net=host) possible pass in access to hardware like zwave dongle, and mount it set up data volumes to persist your config from one run to the next.

The full set of arguments recommended are on the dockerhub page.

Many of us successfully run in Docker, though if you are running OH on an RPi, the benefits of doing so are not so great.

So I tried including all of the arguments, at least what I could comprehend.
still locks up at launching runtime.
I’m sure my code is still not correct.
I am going to take @rlkoshak advice and for the moment just go with no docker.
I pretty much burned myself out on it for this fine day.
Thank you ALL so much for your insight and valuable time and effort in not just me but EVERYONE.
What a awesome forum this is and we are very fortunate.