OpenHab/Raspberry pi unavailable

I have a raspberry pi/openhab installation that will become unresponsive. After a day or so I cannot log into the raspberry pi using putty. I was thinking it was the wireless chip so I added a cron job to reset the wlan but it did not help at all.

Has anyone seen the same issue

time=$(date “+%Y/%m/%d %H:%M:%S”)

ret=$(ping -c 2 -W 1 -I $NetCard $PingTarget | grep ‘received’ | cut -d ‘,’ -f 2 | cut -d ’ ’ -f 2)

if [ “$ret” == “0” ]; then
sudo ifdown wlan0 && sudo ifup wlan0
echo “Try Reconnect: $?, $time” | tee -a $LogFile
if [ “$LogAll” == “true” ]; then
echo “Network is ok, ret = $ret, $time” | tee -a $LogFile

exit 0

Maybe disable power saving for wifi?

Already tried that sorry forgot to mention

lo no wireless extensions.

wlan0 IEEE 802.11 ESSID:“curtis”
Mode:Managed Frequency:2.412 GHz Access Point: 9C:34:26:2F:7A:F8
Bit Rate=65 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70 Signal level=-32 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:15 Invalid misc:0 Missed beacon:0

Try a better power source. This behavior is often, though not always, caused by a power source that is not quite as clean or powerful enough to keep the RPi going.

Tried a Cana kit power supply. No dice still the same issue.

Would you just look in the syslog for the root cause?

I wouldn’t know any better than you do what to look for. You may have better luck posting to an RPi forum.

I switched over to an ethernet connection and the problem seems to be fixed. The wireless could ping and connect to the outside world but nothing could connect into the raspberry pi. It is a really odd problem with the wireless driver