Openhab running, but not listening on port 8080/8443

  • Platform information:
    • Hardware: up² Intel N3350
    • OS: Linux Ubuntu 18.04 LTS
    • Java Runtime Environment: openjdk 1.8.0._181, Zulu
    • openHAB version: 2.3.0 Release Build
  • Issue of the topic: Fresh install of openHAB 2.3.0, its running but it does not listen to port 8080 or 8443, it listens to no port what so ever, if I try to use openhab-cli console it asks me for a user but openhab:habopen is not working, the /var/log/openhab2/openhab.log tells me Lockacquuired Setting startlevel to 100
  • Please post configurations (if applicable): NONE, Fresh install
  • If logs where generated please post these here using code fences:
    If I start sudo openhab-cli start --debug I can see an error
    Error in initialization script: /var/lib/openhab2/etc/shell.init.script: /var/lib/openhab2/etc/shell.init.script
    And still no port bind to 8080 or 8443
    Ports that come from openHAB are 5005 which states the openhab-cli is “Listening for transport dt_socket at address: 5005”

I tried to reinstall openHAB 2.3.0 5 times from scratch via apt, everytime deleted all config, all old files, even with restart etc. still no success.

Hi Can you please give us log ?
and also your run sudo netstat -plnt and give that output as well
will tri and help.

Thanks for your effort, but cant do that right now. Other work todo…

What I can tell you now is that the openhab.log says
Lock acquuired Setting startlevel to 100

And I checked netstat -tulpen as root and no application was running on port 8080 and 8443

The karaf console stated
Error in initialization script: /var/lib/openhab2/etc/shell.init.script: /var/lib/openhab2/etc/shell.init.script

did you follow the steps when you removed the old openhab install ?

sudo apt-get purge openhab2*
sudo rm /etc/apt/sources.list.d/openhab2.list

Purge yes, but where is the point of removing apt list?

you run the command after the purge. then you need to do the whole apt install from the beginning ?

will get some more details and links for you . as soon as I am home.

Just that you know, I am not a noob to openHAB I have setup over 20 instances of openHAB. Started with openhab 1.7/1.8 so I am familiar with the installation procedure. Manual, APT, Docker and openHABian are nothing new to me.

It’s just this one instance which is acting up :rofl:

sorry I am still a nobody and now trining to help you. but will get it right. will battle but will get answers.

I did not mean to make you feel bad or anything, just wanted to let you know this ain’t the first time for me :smiley:
I am always happy if someone from the community is trying to help, that’s one of the best things about this community.

That’s very wrong, alone the fact that you try to help and already contributed to the community makes you a valuable member of this project! So I encourage you to keep helping even if someone like me seems a bit sassy (sorry for that :smiley: )


Hahaha. Typo. Noobee

Ahhh noob not nobody, my statement stays the same :+1:
Let me guess, mobile phone keyboard? Happens to me all the time :rofl:

Yes. Lol. On the road. So use phone alot

Thank you. I try and learn alot. And help where i can . It helps me also. When i battel with it

Did you get to the bottom of this @BrutalBirdie? I’m seeing a similar thing when installing a new OpenHAB.

wow. thats a necro bump.

Well the bottom of it for me was an IPv6 issue I think.
I am not sure anymore sorry.