OpenHAB suddenly stopped and won't start

For some reason OH stopped working yesterday. I run OH on Debian Jessie, I have changed nothing for the past month, I have not even done a apt-get update. I run OH 1.8. I noticed the problem because I got a notification from my.openhab that OH was offline. When I try to start OH I get following error:

!SESSION Sun May 08 12:48:34 UTC 2016 ------------------------------------------ !ENTRY org.eclipse.equinox.launcher 4 0 2016-05-08 12:48:34.770 !MESSAGE Exception launching the Eclipse Platform: !STACK java.lang.InternalError: internal error: SHA-1 not available. at at<init>( at at<init>( at$TempDirectory.<clinit>( at at org.eclipse.equinox.launcher.Main.canWrite( at org.eclipse.equinox.launcher.Main.checkConfigurationLocation( at org.eclipse.equinox.launcher.Main.basicRun( at at org.eclipse.equinox.launcher.Main.main( Caused by: SHA MessageDigest not available at at at at ... 10 more

Any help would be appreciated.

Thank you,


If you REALLY didn’t change anything, check your sd card, it may be worn out …

I don’t think it’s a problem with the SD card, Everything else works fine, I have mosquitto and node-red running, they both work fine and they too have not changed in over a month. In any case, what does the SD card have to do with the error I’m getting?


sd cards tend to worn out after a while, you’ll find many examples in this forum.
Try to copy (dd for example) the content to a new card and see what happens …

copy imaged my SD card to a new SD card and there is no change.

Did debian somehow update in the background? Looks like SHA-1 cryptography module for java isn’t available for whatever reason. Why that’d disappear on an otherwise functioning system I have no idea outside of an update going awry.

I cannot find any reference related to your error message, sorry …
I have had a worn out sd card twice in 18 months with weird error messages, so I thought it could help in your case too.

Have you got more than one Java installed? I would double check that you are running what you think you are running:

java -version