Openhab-ui-basic fails to start


I just updated my 2.3 snapshot.
Now I see the error:

2018-03-16 18:01:54.183 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-http1, openhab-binding-exec, openhab-misc-market, openhab-binding-irtrans1, openhab-misc-openhabcloud, openhab-persistence-influxdb, openhab-binding-modbus1, openhab-ui-habpanel, openhab-transformation-regex, openhab-misc-ruleengine, openhab-transformation-jsonpath, openhab-persistence-rrd4j, openhab-ui-basic, openhab-ui-classic, openhab-action-mail, openhab-binding-tradfri, openhab-binding-astro, openhab-ui-habmin, openhab-binding-squeezebox, openhab-binding-homematic, openhab-transformation-exec, openhab-binding-knx, openhab-ui-paper': Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-ui-basic; type=karaf.feature; version="[2.3.0.SNAPSHOT,2.3.0.SNAPSHOT]"; filter:="(&(osgi.identity=openhab-ui-basic)(type=karaf.feature)(version>=2.3.0.SNAPSHOT)(version<=2.3.0.SNAPSHOT))" [caused by: Unable to resolve openhab-ui-basic/2.3.0.SNAPSHOT: missing requirement [openhab-ui-basic/2.3.0.SNAPSHOT] osgi.identity; osgi.identity=org.openhab.ui.basicui; type=osgi.fragment; version="[,]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.ui.basicui/ missing requirement [org.openhab.ui.basicui/];; bundle-version=0; filter:="(&(>=0.0.0))" [caused by: Unable to resolve org.eclipse.smarthome.ui.basic/ missing requirement [org.eclipse.smarthome.ui.basic/] osgi.wiring.package; filter:="(osgi.wiring.package=org.eclipse.smarthome.core.types.util)"]]]

Or the important part (I guess) out of this long message:
Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-ui-basic;

Any thoughts or hints what is going wrong?

… after editing
and removal of the basic-ui

the system comes back to live…

??? Any suggestions???

1 Like

Same problem here!
Removed the basic-ui, as you said, so I can login to paper-ui at least.
But: my homematic-base thing is stuck in “initializing” state!
Panic :wink:

I had that problem as well. Only copying an older 2.3 snapshot installation from a clone gave me a working system again. Using an older deb didn’t help as it downloaded the all new add-ons. (Basic-ui is my main interface so i couldn’t simply remove. I tried it, but i couldn’t install afterwards)

Maybe this was due to being in the middle of a big upgrade, but i will not test that right now, because my system is working again.

If you don’t have a running system you could/should try again.

Try to upgrade to the lastest snapshot Build #1231, it solve the problem for me

Did it. Worked. :smiley:


what is Build #1231?
is not last release?

The build# is shown in the bottom when you go to openHAB in your browser.

thank you Joachim, I have not reached that step yet because I have the issue as this post
Openhab-ui-basic fails to start

I found out my version is openHAB 2.3.0 Build #1203.
where can I download Build #1231?

What os are you using? If you are debian based, apt-get update and apt-get upgrade should help

Hello Joachim
I am using synology dsm 6.0

now I install old version 2.2 and works

I just installed openHAB 2.5.0 Build #1526 and am getting the same type of error. Any ideas?

2019-02-20 15:29:16.484 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-ui-homebuilder, openhab-ui-basic, openhab-ui-paper'
1 Like

Same Problem here.

It’s due to the UI addons having been moved to the openhab-webui repo. I’ve created a PR which should fix this:

1 Like

i have the same issue, is there any quick fix i can do ?

The quick fixes I can think of:

  • restore backup (if you’ve made one)
  • downgrade to working snapshot/milestone
  • add UI addon JARs to /addons dir
1 Like

i had to rollback to a lower build number, which fixed the issue, hope it is fixed soon :slight_smile:thanks