openHAB Windows Beta App

Hi, since Openhab 3 i cant use the Windows App anymore.
If i Open the App i get the Message: “Not able to parse runtime verion from openHAB server”
The App Log is:

13:50:57;INFO;OpenHAB.Windows.App+<OnLaunched>d__3.MoveNext;=== Start Application ===;;
13:50:57;INFO;OpenHAB.Core.Services.SettingsService.Load;Load settings from disk;;
13:50:57;INFO;OpenHAB.Windows.ViewModel.MainViewModel+<LoadData>d__52.MoveNext;Load available sitemap's and their items;;
13:50:57;INFO;OpenHAB.Core.Services.SettingsService.Load;Load settings from disk;;
13:50:57;INFO;OpenHAB.Core.Services.SettingsService.Load;Load settings from disk;;
13:50:57;INFO;OpenHAB.Core.SDK.OpenHABClient+<SetValidUrl>d__14.MoveNext;Validate Url;;
13:50:57;INFO;OpenHAB.Core.SDK.OpenHABClient+<SetValidUrl>d__14.MoveNext;App is running in demo mode: False;;
13:50:58;INFO;OpenHAB.Core.SDK.OpenHABClient+<SetValidUrl>d__14.MoveNext;Metered Connection Type: False;;
13:50:58;INFO;OpenHAB.Core.Services.SettingsService.Load;Load settings from disk;;
13:50:58;INFO;OpenHAB.Core.Common.OpenHABHttpClient.InitClient;Initialize http client for connection type 'Local';;
13:50:58;INFO;OpenHAB.Core.SDK.OpenHABClient+<SetValidUrl>d__14.MoveNext;OpenHab server is reachable: True;;
13:50:58;INFO;OpenHAB.Core.Services.SettingsService.Load;Load settings from disk;;
13:50:58;INFO;OpenHAB.Core.Common.OpenHABHttpClient.InitClient;Initialize http client for connection type 'Local';;
13:50:59;ERROR;OpenHAB.Core.SDK.OpenHABClient+<GetOpenHABVersion>d__7.MoveNext;Not able to parse runtime verion from openHAB server;;
13:50:59;ERROR;OpenHAB.Windows.ViewModel.MainViewModel+<LoadData>d__52.MoveNext;Load data failed.;"OpenHAB.Core.Model.OpenHABException: Not able to parse runtime verion from openHAB server
   at OpenHAB.Core.SDK.OpenHABClient.<GetOpenHABVersion>d__7.MoveNext() + 0x310
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() + 0x21
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task) + 0x70
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task) + 0x38
   at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task) + 0x17
   at System.Runtime.CompilerServices.TaskAwaiter`1.GetResult() + 0x10
   at OpenHAB.Windows.ViewModel.MainViewModel.<LoadData>d__52.MoveNext() + 0x359
";Action.Invoke =>  => ExecutionContext.Run =>  => Action`1.Invoke =>  =>  =>  => <LoadData>d__52.MoveNext

I use openHAB 3.1.0.M3 and the latest Windows Openhab Beta App 2021.2.23.0
Is there some Setting in Openhab i miss to set?

My App Setting:

1 Like

Happening here too… I’m on M5 and having the same error on the windows app:

“Not able to parse runtime verion from openHAB server”

Tried both versions, beta and final.

Hey @elcosomalo and @DaHarry
Thanks for reporting.
I will have a look on the issue in the next days

1 Like

Hi Christoph!

Any news on this?

There was a certification issue with the update 2021.2.26.0 and so I published the same update with minor changes as a new build (2021.7.7.0), which is now available in store.


  • Start App on windows logon (#190)
  • Support high resolution icons for widgets #189
  • Notification Support #188


  • Not working with openHAB 3.1.0.M5 #192

The fix from @cd-tronic is now part of the new beta release.

1 Like

New beta update (2021.7.11.0) is available.


  • Icons not updateing correctly #195

I would also propose this build as release for the major app, if there is no bigger issue with the build.

Release notes for major update:


  • Visibility Condition #94
  • Value and Label Color Condition #76
  • Text Trimming for Widget labels and Text Widget value #75
  • Replaced old SwitchWidget with new implementation based on Toggle Switch #44
  • Adding support for ColorPicker/Color element #73
  • Start App on windows logon #190
  • Support high resolution icons for widgets #189
  • Notification Support #188


  • Not working with openHAB 3.1.0.M5 #192
  • Icons not updateing correctly #195

Release is now available as update for the major app with version 2021.7.13.0.
See release thread

Hi guys!
Found another bug, the app is not showing the correct settings that are currently applied for the things I have (in this case “Color ambiente”). That worked on previous versions, only the color was reset, but now the brightness is also reseted.

Changing a value from the app as it is in the image (with wrong values) makes them the new values so if I touch the brightness on the app now as shown in the screenshot, the color would be reset to white and 0% brightness.

Not something that breaks functionality but just to let you know.


The color picker seems to be broken somehow, to update the values I have to move the brightness bar so it updates to the new values I set.
It is also interfering with the “fader dimmer” rule: Rule to slowly fading in or out any given item based on variables
(It causes the script to always think the last value is %100)

None of these problems happen if I use the sitemap panel in the browser.


what Version ob OH do you use?
I also found some strange bevaviour since updating to 3.0.M5.
I had no time to update to the latest version.

I’m on OH 3.1.0. and using the Beta windows app.

Hey @cd-tronic,
Have you time to check the issue?

In the last update I implemented a value check for a valid RGB within the SetState function of the ColorWidget control to avoid app crashes. Maybe this could be the reason why the value for the controls are not set.

@elcosomalo Can you check the app log (Settings->View Log) if there is warning entry with the following text: “Item state ‘{rgbString}’ is not a valid RGB value”. It would be good to know what kind of values ({rgbString} is the placeholder for the value) the control tries to parse.

Yes sir, here is it:

Seems “338.260864,27.058825,13.000000” is not a valid RGB Value (0-255).
@elcosomalo What kind of thing and item is configured in OH?

They are 2 RGB lightbulbs and 1 RGB led strip(which is on the back of the TV, this is for better understanding of the data below) :


    Thing topic RGB           "Lampara RGB 1" {
            Type colorHSB : LampRGB  [ stateTopic="stat/RGBbulb1/HSBColor", commandTopic="cmnd/RGBbulb1/HSBColor" ]
            Type switch : LampSwitch [ stateTopic="stat/RGBbulb1/POWER", commandTopic="cmnd/RGBbulb1/POWER"]
            Type dimmer : LampCT     [ stateTopic="stat/RGBbulb1/CT", commandTopic="cmnd/RGBbulb1/CT", min=153, max=500]
            Type dimmer : LampDimmer [ stateTopic="stat/RGBbulb1/Dimmer", commandTopic="cmnd/RGBbulb1/Dimmer"]    

    Thing topic RGB2           "Lampara RGB 2" {
            Type colorHSB : LampRGB2                     [ stateTopic="stat/RGBbulb2/HSBColor", commandTopic="cmnd/RGBbulb2/HSBColor" ]
            Type switch : LampSwitch2                    [ stateTopic="stat/RGBbulb2/POWER", commandTopic="cmnd/RGBbulb2/POWER"]
            Type dimmer : LampCT2                        [ stateTopic="stat/RGBbulb2/CT", commandTopic="cmnd/RGBbulb2/CT", min=153, max=500]
            Type dimmer : LampDimmer2                    [ stateTopic="stat/RGBbulb2/Dimmer", commandTopic="cmnd/RGBbulb2/Dimmer"]

    Thing topic TV_RGB           "TV LEDS RGB" {
            Type colorHSB : LampRGB3                     [ stateTopic="stat/TV_RGB/HSBColor", commandTopic="cmnd/TV_RGB/HSBColor" ]
            Type switch : LampSwitch3                    [ stateTopic="stat/TV_RGB/POWER", commandTopic="cmnd/TV_RGB/POWER"]
            Type dimmer : LampDimmer3                    [ stateTopic="stat/TV_RGB/Dimmer", commandTopic="cmnd/TV_RGB/Dimmer"]


Color	LuzRGBHUE     	"Color luces RGB"        	 <colorlight>   {channel="mqtt:topic:local:RGB:LampRGB", channel="mqtt:topic:local:RGB2:LampRGB2", channel="mqtt:topic:local:TV_RGB:LampRGB3"}	
Switch	LuzRGBSwitch    "Switch luces RGB"    	     <lightbulb>	{channel="mqtt:topic:local:RGB:LampSwitch", channel="mqtt:topic:local:RGB2:LampSwitch2"}
Dimmer  LuzRGBCT        "Temp Fria/Calida luces RGB [%d]" <lightbulb>	{channel="mqtt:topic:local:RGB:LampCT", channel="mqtt:topic:local:RGB2:LampCT2"}
Dimmer  LuzRGBDimmer    "Dimmer luces RGB"           <lightbulb>	{channel="mqtt:topic:local:RGB:LampDimmer", channel="mqtt:topic:local:RGB2:LampDimmer2"}

Color	LuzRGBTV     	 "Color luz RGB TV"    <colorlight>      {channel="mqtt:topic:local:TV_RGB:LampRGB3"}	
Switch	LuzRGBTVSwitch   "Switch luz RGB TV"   <lightbulb>	 	 {channel="mqtt:topic:local:TV_RGB:LampSwitch3"}
Dimmer  LuzRGBTVDimmer   "Dimmer luz RGB TV"   <lightbulb>	     {channel="mqtt:topic:local:TV_RGB:LampDimmer3"}

Switch  TodaslaslucesRGB       "Switch todas luces de colores"  
Dimmer  Todaslaslucesdimmer    "Dimmer todas luces de colores [%d]"   {channel="mqtt:topic:local:RGB:LampDimmer", channel="mqtt:topic:local:RGB2:LampDimmer2", channel="mqtt:topic:local:TV_RGB:LampDimmer3"}

I don’t think this is really an RGB Value as i didn’t find Oh working with RGB anywhere.
It’s always HSV.

I will try it tomorrow. Maybe i could find a way to reproduce the issue

Agree seems its HSV values and I implemented the regex with a wrong assumptions, because I interpreted values I got from my HUE lamps as RGB.

So I will adjust the regex like this to allow decimal values.

I’m not shure if this is the right regex for this.
Doesn’t work if i thow it into an regex debugger.
But in fact i’m not that keen on regex but this might be better?

Just an update… the error that I was having in the app’s log is gone. I found a rule conflicting with the values… but the problem on the app is still there, it doesn’t update the correct color value on the color picker.