OpenHAB won't recognise zwave dongle


I’m a complete beginner struggling to get openHAB to see my Aeon Labs gen5 zwave stick. I’m running Ubuntu 14.0.4 on an odroid, and openhab is installed and working with the zwave binding.

lsusb shows the device as: "Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. " dmesg shows the device at ttyACM0

So in openhab.cfg I set “zwave:port=/dev/ttyACM0”

But nothing seems to happen - habmin doesn’t see the device and if I attempt an include I get “error sending action to the server”.

Would really appreciate any tips…

1 Like

Hi Dan,
Having just answered a message from you about reducing logging, this is where I ask you to increase logging :smile:

Really, to be able to tell what’s happening, I’d need to see the DEBUG log from the zwave binding. In the zwave wiki there is an explanation of how to enable this (by editing the logback.xml file I mentioned in the previous post)…

The error that you’re getting from HABmin though is a little concerning - it would potentially point to the zwave binding not running at all, but really without the log it’s hard to say for sure…


Sorry, I’m really not very good at this. I added the text from the wiki into /etc/openhab/logback.xml - after the “EVENTFILE” appender. I then restarted openhab and tried including from habmin again. No log file anywhere (I checked with “find” in case it went into the wrong directory). I assume I’m missing something obvious…

thanks for your help!


One possible explanation - if you start OH using the debug script file, then it will call up a different version of the logback file (logback_debug.xml).

unfortunately that’s not it - I copied my logback.xml over logback_debug.xml and still no zwave logging

please be aware that,differently from what is stated in several sources, for me the stick was attacched to ttyACM0 and not ttyUSB0.
I suppose you have set that parameter in openhab.cfg zwave section.

Also note that, if you have a lot of bindings jar in the addon folder it will take a lot of time for things to startup

check the other thread I opened asking for similar help (search cp210).

1 Like

Maybe we should go back to my earlier comment -:

If there’s no log, and zwave isn’t working, and you’re getting the “error sending action” error, then maybe zwave isn’t running at all…

Is the zwave JAR loaded in the addons folder, and is it the correct size (About 1.1MB I think).


many thanks for looking at this.

org.openhab.binding.zwave-1.7.1.jar is in the addons folder, and is indeed 1.1MB

I had installed using apt-get; I wonder if I should start again and install openhab manually?

(In reply to the others; not an old version of the jar file; I am using ttyACM0; not many bindings and I’m giving it plenty of time to startup)

OK - this is solved. The problem turned out to be that I am an idiot. A number of the guides online caution that if the zwave device uses tty and the openhab user does not have root privileges then they need to be added to the “dialout” group. I didn’t create an openhab user and my default user is a member of dialout - so I thought that was that. But then looking at the running processes I see that apt-get did create an openhab user, so I do need to add to the dialout group.

Everything is now behaving.

Many thanks for all your help, and apologies for wasting your time.


Ah - the most common problem of all :smile:

I’m glad you’re up and running - no problem about “wasting” time…


I am actually having this same problem (feeling the idiot part as well!).

Complete beginner with OH. Running OH 1.7.1 on an RPI2 Raspbian wheezy.

I have a 1.1 M Z-Wave binding jar in my addons folder. dmesg shows my Gen5 Aeotec USB as ttyACM0, so it is loaded in my openhab config as zwave:port=/dev/ttyACM0. openhab user has been added to the dialout group.

When I go into Habmin -> Configuration -> Bindings -> Z-Wave and do pretty much anything on the Devices tab, it tells me “error sending action to the server”.

I’ve split off my zwave debug logs via logback.xml like the wiki shows, but this is all the zwave log shows me (restarted OH service as well):

2015-11-19 21:20:40.668 [DEBUG] [.zwave.internal.ZWaveActivator:36 ]- Z-Wave binding started. Version 1.7.1
2015-11-19 21:20:40.727 [DEBUG] [.z.internal.ZWaveActiveBinding:175 ]- ConverterHandler not initialised. Polling disabled.
2015-11-19 21:20:40.733 [INFO ] [.z.internal.ZWaveActiveBinding:317 ]- ZWave ‘updated’ with null config

Any advice/help would be most appreciated!!

It looks like there is no configuration set. What is in your config file?

openhab config? It has zwave:port=/dev/ttyACM0 and the heal time set for 2 AM.

Looks like I got it working. Was missing a couple things…

In openhab.cfg:
Set SUC Mode to disabled
Enabled master controller mode

In openhab startup script:



I am getting the same error that you have in the zwave.log file. What do you mean that you set SUC mode to disabled in the openhab.cfg file? I already have mine set to the zwave:masterController=true. Mine is apparently on /dev/ttyUSB0

Also, did you add those lines in the or file? There is nothing in my startup files that show the port for zwave.


I randomly noticed the SUC mode thing on the Z-Wave Binding page in HABmin, but it wasn’t on the Z-Wave Wiki, and it isn’t listed in the openhab.cfg file/commented out like some of the other settings. After finding it in HABmin, I found more details after some searching. Here is the code:


Here are some more details on what SUC mode does:

For the startup script, I had to modify the mine in /etc/init.d/openhab. Here is the guide I had used:

Good luck! Let us know how you make out :smiley:


I added the code for wave:setSUC=true and it worked for a while, but the next reboot, I got the port does not exist error in the log again.

I modified the startup script using the link you provided and I am still getting the port does not exist error… I will continue to tinker with it. Thanks for the help, I do appreciate it!


Sounds like that might be your startup script that needs to be adjusted. Have you tried typing dmesg just to be sure you have the right port? You can also use ls /dev/tty* to check. If you have the Aeotec stick, have you added any devices to it? Check out the little booklet that comes with it which explains about inclusion mode (and taking it out of inclusion mode when you connect it back).

Here is my config file for the hell of it:

zwave:port = /dev/ttyACM0
zwave:masterController = true
zwave:healtime = 2
zwave:softReset = false
zwave:setSUC = false

I have a Aoetec z-stick 2 with about 20 or so z-wave devices on it. It runs perfectly fine controlling the devices in Indigo 6. OpenHAB is now seeing my z-stick, the problem is, it is not seeing any devices that are already on it. I tried to set up my home.items file with the nodes that were assigned by Indigo 6… but they don’t appear to be correct. I tried commenting out all of my z-wave items in my home.items file, but that did not fix anything.