OpenHab2.2 on Linux PowerPC

Hi all,

I have an old Apple G4 PowerPC with Ubuntu 16.04 and openJDK 1.8.0_151, when I try to run openHab.

I got this error:
Launching the openHAB runtime…

A fatal error has been detected by the Java Runtime Environment:

Internal Error (cppInterpreter_zero.cpp:831), pid=5278, tid=0xb783e460

Error: Unimplemented()

JRE version: (8.0_151-b12) (build )

Java VM: OpenJDK Zero VM (25.151-b12 interpreted mode linux-ppc )

Core dump written. Default location: /home/mirko/Documenti/openHab/openhab-2.2.0/userdata/core or core.5278

An error report file with more information is saved as:


If you would like to submit a bug report, please visit:

Aborted (core dumped)

What is this error? Can openHab run on PPC architecture ?

Bye Mirko

Your error is a java error and as such unrelated to openHAB in the first place.
OpenHAB runs on Java, so in principle yes it can run on PPC.
But is it a good idea? No. There’s likely noone but yourself who ever tried, so there’s all sorts of yet-to-be-discovered bugs and you’re totally on your own here.

try Zulu or Oracle JVM

Hi all,

Oracle doesn’t support PPC architecture.

I have solved with Zulu, on their web site they have only PPC 64bit JVM available for download, but I’ve asked if they have also 32 bit.

The respond me wery quickly and provide me a secure download for 32 bit version.

Now I have openHab fully working on an Apple Powebook G4.



Just adding a few keywords to this discussion so others will find it through search:
Running OpenHab on Apple Macbook G4 with PPC32, PPC, PPC 32bit, PowerPC using Azul Zulu JVM.