OpenHAB2 - Addon install through paper UI - Habmin - Other primer questions

New to OpenHAB - CERTAINLY new to OpenHAB - but if I’m just starting I mine as well!

Background: I’m a linux sys admin that can develop pretty well in JS, JAVA, Python and PHP - If anything obviously the JAVA piece will help most - but again, sys admin (not a full on awesome developer).

I had a few questions and figured the forum was best since the documentation on OH2 is a bit… light?

2.0.0-SNAPSHOT (Offline download)
Build #444

  1. Executing start.sh - Typically I don’t like to do these things as root (or sudo) - and in the old version you could specify what user “owns” the daemon, but I don’t see that in the new version? I’m guessing because this is controlled by Karaf? Which doesn’t help me as I don’t have much experience with that particular Apache project. I notice when I run as my user - it has issues with the /var/lock - which is interesting as that is a 777 directory so unless a lock was existing there (I checked) as root from a previous start it shouldn’t be an issue. But I get no zwave binding when executed as a standard user. Even though that user owns all dir and files.

  2. Habmin addon. It says version 2.0 snapshot and the jar when I search for it also reflects that but all the talk of the new UI and when I click Habmin instead of paper UI - it shows the old UI and won’t come online.

  3. Maybe pertaining to bullet 1 - I can’t seem to update my one zwave device. It’s the cheaper version 2 phase Aeon labs HEM - I can get the values for it (haven’t done persistence / graphing yet - getting there) - but when I go to edit it in Paper UI - I set the values - hit the checkbox to save and it gives me 404 not found in the little message box. The XML isn’t updated, and the settings revert. If I update in the XML manually - it does show after a reboot of OpenHAB2.

I think that’s it for now. I’m happy to help this thing forward - it’s awesome. I was using another Home Automation suite (which shall not be named) but it was destroying my linux Intel NUC it runs on. Seeing this is all in JAVA and testing with good results makes me excited!

Thanks!

Also! As a separate note (which is why I’m replying and not editing) - Anything from OH1 that I can read up on to better understand? I ran it for like 1 day messing around until I decided that was dumb and to switch to OH2 so some simple theories like Groups, Sitemaps etc still are a little foreign to me. They used here in OH2 as well? I should probably read up.

If you are OK with running a slightly older stable release of OH rather than the nightly builds, you might consider the apt-get installation.

http://docs.openhab.org/installation/apt.html

It will create an openhab:openhab user and do the systemd (or upstart if that is your system) so it starts as a service.

Another alternative is the Docker container. There is an official openhab image for OH 2 which I think pulls from the nightlies.

I don’t think the owner of the process is controlled by Karaf. In fact OH runs on top of Karaf so Karaf’s user is OH’s user.

Are you sure it is /var/log that is the problem, or could it be that the user you are trying to run under is not a member of the dialout group (or whatever the group is on your device)? That is the typical permission problem with zwave. This problem will also pop up when installed as apt-get.

Pretty much everything from the OH 1 wiki pages will be somewhat useful to you. Sitemap syntax is the same. Rules are the same. Persistence is the same. Manually defining Items is mostly the same. And all of the OH 1 bindings can work in OH 2 through a compatibility layer.

Hey guys, a lot actually changed (to the better) regarding this: https://github.com/ThomDietrich/openhab-docs/blob/d8b8640ec790f865128e7b5e2dfd263b86140fe8/installation/linux.md

You will find a way to install the latest snapshot through apt.
On a further note: What @pr0f is actually asking about (non-root execution) is not yet in there. Just didn’t have the time to test it. On the plus side: almost everything else was tested (Raspbian lite)

Update: now all available at http://docs.openhab.org/installation/linux.html

1 Like

Sorry for asking questions not really related to the topic, but I see that you are running OH on an Intel NUC.

After having run OH on two different ARM-based systems (Raspberry PI 2 and ODROID C1+) both of them ending up in a state where they need a complete reinstall (no fault of OH!) I am in the market for a proper “high quality - or at least high enough quality” Intel-based system to run OH on.

I have been looking at Intel NUC but there are so many variations that I simply have not been able to make up my mind about which one strikes the best compromise between what I want and what my wallet can accept.

Do you mind sharing what version you are using, and what your experience with this is?

Ps! As you, I will be running Linux (most likely Ubuntu or Mint) on the NUC.

@ThomDietrich Thanks for the input! I’ll give that build process a shot! I like the docs you got on your GitHub - a bit better than the “docs site” advertised for official docs for OH2.

@KjetilA - There are a bunch right? And lots of versions since they started. Versions between old and new have some differences but I don’t recall what they are to be honest. BUT - between the different “sized / performance” I can tell you that I happen to run the big boy (still like 17W compared to the old server tower at 400W!! (I’m an electric conservation nut!)) The I7. Gen 4 (or 5?) which ever one is the last one (not current). I run an I7 because I run a bunch of different things on it - not just Home Automation. So it’s I7 whatever the max CPU is (not home to check) and 16Gb of Ram with a SSD. Note that they don’t come with RAM or HDD.

If you were JUST running OH2 on it - you could EASILY do this with the I3 with 4GB of RAM. The one reason I run the big boy is one of my programs is Plex - which is transcoding multiple streams of AV.

You could even do a AMD based system if you wanted to save cash - I don’t know what the difference in energy usage is but it would be able to handle it as it’s still way more juice than a Pi.

Hope this answers your questions. Ubuntu headless runs like a champ on it. And I have over 5 Apps for various things and they all run seamlessly.

I owe you a beer dude :slight_smile:

Thank you for pointing me in the right direction. The process that successfully installed OH2 was /github.com/ThomDietrich/openhab-docs/blob/d8b8640ec790f865128e7b5e2dfd263b86140fe8/installation/linux.md

Now to hit the learning curve…

Hey @pr0f, Hey @UglyKidJoe,

just so you know: The official openhab docs at docs.openhab.org are managed as a github repository. The link I posted points to an article I just created last week and which is open for review right now.

Update: The finished version of the article, including restricted permissions (execution as user openhab), is now available.

1 Like

Thank you Thom, it looks like a quality document!

I’m busy doing a fresh install for my ‘production pi’ based on it. Any issues I’ll let you know.

It’s great that you included details like installing and setting up samba. Things like that go a long way in helping new users get up-and-running, so thanks again for the information.

Thanks man, happy to hear that :wink:

You might be happy to hear that I am also currently working on a preconfigured Rasbian setup as way too many users waste time and nerves on these trivial details.

Hava look :wink: openHABian hassle-free openHAB Setup