OpenHab2 - Alexa (Echo) - Phillip Hue Farbe

hue
openhab2
alexa
Tags: #<Tag:0x00007fae03de59f0> #<Tag:0x00007fae03de51f8> #<Tag:0x00007fae03de4618>

(Kleemann) #1

Hello,

I am currently confronted with a problem which I have not yet found a solution to by searching the forum.
I have installed Openhabe 2 on a RaspberryPi 3 (Debian).
Now I bought the Echo Dot (Alexa) 3 days ago and already managed to connect to my OpenHab2 system via Alexa’s skill.

Now that I have saved my lamps (Phillip Hue - Color) in a *. items file, I can already switch them on/off and dim them.
But if I say so now:
“Echo, set[Lamp] to[Color]”,
I only get the message “[Lamp] does not support this”.

Here’s my configuration:
Color Hue01 “Corridor 1st floor” (gflor, gLights)[“Lighting”] { channel=“hue: 0210: **********: 1: color” }
Color Hue02 “Corridor EG” (gFloor, gLights)[“Lighting”] { channel=“hue: 0210: **********: 2: color” }

Hope someone can help me.
Greetings from Brandenburg
Kleemann


(SiHui) #2

Your channel definition is wrong, take a look at the docs:

http://docs.openhab.org/addons/bindings/hue/readme.html#demoitems

Color Light1_Color { channel="hue:0210:1:bulb1:color" }

And please write in English language so everyone in this international forum can benefit.
If you need to write in German language you may use a German language forum:


(Kleemann) #3

Hi there,

first thanks for you answer. I’ve translated my question to english.
I have to say, that i don’t really understand the difference of your an my definition.
I’ve just masked my hue-bridge-id with star-chars (*) but should i not keep the groups etc. in my defintion and moreover what is the difference of you channel-definition and my?

Sorry for that, may stupid question

best regards


(SiHui) #4

No, now that you’ve changed your original post there is no difference anymore :sunglasses:
BTW, it is not my definition, it is the definition from the official docs.

I would recommend to read through the - long - thread here where most if not all of the Alexa problems are solved:


(Kleemann) #5

I’ve still not found a working solution yet. Anyone has more ideas.
I think the problem is in generell, that my alexa is not able to change to value of a Color item, because even if i remove the hue-binding from the item it won’t change the color and just return: “[Item] does not support this”


(SiHui) #6

I don’t know if this is still true:

As a workaround you could install the HUE skill on your Alexa and change the color without intervention of openHAB.
Works without any problems.


(Alex) #7

I use “Openhab Skill for Alexa” with “openhab Cloud Service” in german. Color changing is working perfect.

For each Hue Color bulb I use 3 items .

Switch … [ " Lighting" ]
Dimmer… [ “Lighting” ]
Color… [ “Lighting” ]

… and putting them together in the same Alexa-Group.


(Philipp) #8

i dont have the HUE - but your code looks different to sihui:

your code

 { channel=“hue:0210:bulb:1:color” }

correct Syntax:

{ channel="hue:0210:1:bulb1:color" }

the “:1:” in front of the BULB not afterwards


(Alex) #9

@Kleemann

@RiotMode and @Sihui are NOT right.

The syntax is:

{ channel="hue:0210:xxxxxxxxxxxxx:1:color" }

see also here:

https://docs.openhab.org/addons/bindings/hue/readme.html#demoitems

BUT THIS IS WRONG!

Replace xxxxxxxxxxxx with your BridgeID:

{ channel="hue:0210:xxxxxxxxxxxx:1:color" }

and there should be NO spaces inside, like in your 1st example!!

I made a screenshot of my Thing from PaperUI, here:


(Kleemann) #10

Hello @Celeano1, thanks for you reply. For sure i’ve not put “xxxxx” in my definition, its just to keep my bridge-id secret.
I als o got no space in the channel-string.

Moreover i’m able to change the color in the openhab but but now with alexa. Thats why i think its a problem of alexa or the interface of alexa and openhab.

I’m also not able to change a Color-item which is not linked to a hue-lampe.

Hope for more suggestions
Best regards


(SiHui) #11

There seems to be a different visual indication if things are configured through flat text files or auto discovered things through PaperUI:

According to the docs, configuration through text files:

Color Light1_Color { channel="hue:0210:1:bulb1:color" } where the single “1” is the bridge id configured through the things file.

Taking a look at the things file for a bulb:

0210 bulb1 [ lightId="1" ]

“Translated” to the items file would mean:

Color Light1_Color { channel="hue:0210:<bridge_id>:bulb1:color" }, the “bulb1” represents the light id=“1”

Taking a look at an auto discovered HUE thing shows:

hue:0210:<bridge_id>:1:color = hue:0210:<bridge_id>:bulb1:color, so we are at the same step as above:

It’s just a matter of configuration …


(Kleemann) #12

What i’ve did is, that i’ve created a new item:
Color Test1 “Test” [“Lightning”]

And let Alexa search for new devices. Alexa even told me that “Test” was found as a new device.
I’ve i now say:
DE: "Alexa schalte Test auf grün"
EN: “Alexa turn Test green”

I only get
DE: "Test unterstützt das nicht"
EN: “Test does not support that.”

Thats why i now think it is not a problem of hue rather than a problem of the ColorItem or alexa. Any suggestion for that?


(Alex) #13

See my Post above:


(SiHui) #14

You are missing the channel configuration … or you need a rule to update the real linked item to your “proxy” item:

rule "Test1 " 
when   
	Item Test1 received command
then
	Test1_Channel.sendCommand(Test1.state.toString)
end

where Test1_Channel is the color item linked to your channel.

But I would not do it that complicated as long as you are trying to make it basically work …


(Kleemann) #15

I’ve now implemented like Celaeno1 said. But still got the message “[Group] does not support that” if i say “Turn [Group] green”


(Alex) #16

@Kleemann
Could you please post your 3 items once again?

What happens if you telling:

“Switch [Group] on/off” is it running?
“Dimm [Group] to 50%” is it running?

I swear, it is running with my Amazon Echo (1st generation) and Echo Dot (2nd generation) in german!!!


(Kleemann) #17

Hello @Celaeno1
for sure.

Switch Test1 “TestA” [ “Lighting” ] { channel=“hue:0210:[MyBridgeID]:1:color” }
Dimmer Test2 “TestB” [ “Lighting” ] { channel=“hue:0210:[MyBridgeID]:1:color” }
Color Test3 “TestC” [ “Lighting” ] { channel=“hue:0210:[MyBridgeID]:1:color” }

And i’ve added these 3 in a group in my alexa app called “Test”


(Alex) #18

@Kleemann
Switch On/Off and Dimming are running with Alexa?

Color not running?


(Kleemann) #19

I can turn on off with
"Alexa schalte Test aus" (Eng: “Alexa turn light off”)
or dimm with
"Alexa dimme Test auf 30%" (Eng: “Alexa dimm Test to 30%”)
it’s work like a charm.

But when i say
"Alexa schalte Test aus grün" (Eng “Alexa turn Test green”)
i got the message
"Test unterstützt dies nicht" (Eng “Test does not support that”)

I’ve already update my hue and tried it with a fresh openhab2 installation


(Alex) #20

@Kleemann

Did you also enable hueemulation? If yes, please uninstall it.