openHAB2 - Amazon Echo Control Binding V2.5.9 - No login possible

Hello community,

I’ve just bought a amazon echo dot (old generation from a friend of mine for 5$) and try to connect it with my openHAB (v2) I’ve downloaded the org.openhab.binding.amazonechocontrol-2.5.9-SNAPSHOT.jar and added it to my addons-folder of openhab2 and for sure restarted the service.
Now i’ve tried to the address from the repo to get the required keys for the amazon-alexa.thing to create for the given plugin (amazon-echo-control) but got the problem, that we i’ve logged in it say I should go into my e-mail account and accept the account-access but in the meantime (after 4-5 seconds beeing on the page) it automatically refrehs and sent me back to the loginscreen.

i’ve read some had similar problems with an older version of the plugin but I think i now have the newest.
Can anyhelp help me?

best regards

You do not have the newest addon version. What version of openHAB 2 are you running in your system?

Hello Bruce,
dpkg --list | grep openhab
openhab2 2.5.1-2 all openhab2
openhab2-addons 2.5.1-2 all openhab2-addons

There you go

You installed the openhab -addons meant for use if you have no Internet. that might stop you from manually installing a binding. I believe the latest version is 2.5.11. There are likely 2.5.12 snapshots too.

Is there a offical folder to get those versions from?
I found my here:

Why not update your openHAB to 2.5.11? The core has not been updated, only bindings to fix bugs.

Is there at least a offical instructure for this procedure? I aspect sure but may i’m just to blind to find

Dince you used the dpkg command I assume you are on a Debian variant of Linux. openHAB updates just like the OS security updates.

sudo apt-get update
sudo apt-get upgrade

Thank you, worked :slight_smile: