OpenHab2 and Linear NGD00Z-4 Garage Door Controller

zwave
z-wave
linear
Tags: #<Tag:0x00007f014c0bb720> #<Tag:0x00007f014c0bb388> #<Tag:0x00007f014c0baf00>

(Wes Warner) #122

@5iver I’ve got the second opener connected and included. When I send 255 to it’s barrier state it makes all the beeps like it’s going to open/close but doesn’t actually move. I can see the state of it change, etc… but the door never starts moving, and eventually the barrier state returns to 0. I’ve verified that the connection is good between the physical button wires, the relay wires from the opener controller, and the opener. Anything else that I can check? I’m trying to get this new one working so that I can then fix the other. Thanks!


(Scott Rushworth) #123

The only thing I can think of is that I recall from the manual that you need to manually open and close the door first in order to calibrate the tilt sensor, but I’ve skipped this in the past and the doors still work. Not moving sounds like a wiring issue to me. Maybe test the leads. I don’t recall of they go to ground or supply a voltage, but I had done bench testing first and picked something up from them.

Are you doing something fancy with the wiring, or are you going straight to the opener?


(Wes Warner) #124

Okay. I’ve cycled it a few times with the physical button, and it’s all good. I’ll bench test.

No fancy wiring. Straight from the controller, twisted with the button wires, and inserted into the actual opener connector. The button works with it as it is, and the bare wires are twisted together, so I’m confident that the controller has a good connection. I’ll bench test them.


(Wes Warner) #125

I’m going to need to get the manual out for the opener too. I just noticed that after the beeping is done, there are some arrows on the opener that are lighting up in some kind of sequence that doesn’t with just the physical button press.


(Wes Warner) #126

@5iver So, the error code my opener is giving me says; " The wires for the door control are shorted or the door control is faulty. Inspect safety sensor wire at all staple points and connection points and replace wire or correct as needed." There is 12VDC coming out of the opener where the physical button and controller connects. I tried to bench test the controller without a 12v source to simulate the opener, but it won’t operate that way (no beeps, etc…). From what I can deduce, the controller monitors the 12VDC, then shorts it to open the door, but the opener doesn’t seem to like this. I’m not at all familiar with how the physical buttons for the openers normally work. Did you encounter anything like this?


(Wes Warner) #127

Okay… Got it working. That being said, there were a few things that were an issue, the first and foremost being that the existing unit, while it was working until I used it last with the Vera (about a month ago), has since failed.

I connected a brand new unit to my other garage door opener (before I knew the original was bad). Turns out that the NGD00Z-4 and the Liftmaster opener I have are not friendly. There is a hardware mod that I tried, but it didn’t help. It was communicating with the OH2 unit though. So, I finally disconnected both NGD00Z units and swapped them. Boom! Two car door was now working just fine, but no 1 car.

The good part about the newer Liftmaster on my 1-car door is that it gives error codes (which it was throwing with the new controller). When I connected the old controller to it, there were no error codes, which leads me to believe that the original controller is actually broken.

Last night I did remove, completely reset (via their instructions), and rebind the original controller and finally got a new node number. So, it acts normal (beeps and receives door state), but does not actually function.

So, I have my 2-car door operating with the new controller, and a broken original controller. Seems I got 2yrs or so out of it. I’ll keep the one that I have for now, but need to find a different solution for the other door.

@5iver Thanks again for your help. I should have warned you that I have the worst luck. It only makes perfect sense that the controller would fail after I used it last. One last question for you regarding your lamda and rules. Does that entire code bit go into the rules file? If so, are there any other add-ons I need to use it? Thanks.


(Scott Rushworth) #128

Sorry… I just noticed you had another question! You probably have this sorted by now, but yes. The rule and lambda go into the rules file. The only other thing you would need is the MAP transformation service.


(Mark) #129

I just ordered an NGD00Z-4 along with this device to integrate it with my Liftmaster opener. I’ll report back how
the installation goes.