Openhab2 and summertime (DST)


(Julian) #1

Hi all,

my oh2 (docker openhab/openhab) has the problem, that it´s is 1 hour behind atm.
for example the item
DateTime Date "[%1$tA, %1$td.%1$tm.%1$tY %1$tH:%1$tM]" { channel="ntp:ntp:myDateTime:dateTime" }
which gets the data from the thing
ntp:ntp:myDateTime [ hostname="de.pool.ntp.org", refreshInterval=60, refreshNtp=30, locale="Europe/Berlin", timeZone="CEST" ]
is one hour behind
when i open a bash inside the docker it shows me (copied from a other post yesterday)
Sat Apr 1 17:22:25 CEST 2017
the item in classicui shows
Saturday, 01.04.2017 16:22

The docker host (synology NAS 916+) has
Sat Apr 1 17:23:47 CEST 2017

The rules time engine is also behind …
neither cron triggered nor getHourOfDay() is working properly


(Julian) #2

really nobody ?
It´s annoying to be one hour in the past :slight_smile:


(Julian) #3

hmmm… a pity that nobody could help me … in the meantime I found it myself:

run docker with

-e EXTRA_JAVA_OPTS="-Duser.timezone=Europe/Berlin"

and it works.

the -v /etc/localtime:/etc/localtime:ro -v /etc/timezone:/etc/timezone:ro

doesn´t seem to have any effect.


(Neil) #4

I cured the summertime problem on my openhab2/synology by setting openhab’s NPT binding to a non-existent NTP server, because then the binding will use the Synology’s system time.

It might be a daft way of doing things, but it’s a daft way of doing things that actually works when nothing else I tried did.


(Gudmund) #5

Hi,

Hijacking and old thread :slight_smile:
I spent a few hours myself and my solution was to add TZ environment variable in the docker-compose.yml file.
EXTRA_JAVA_OPTIONS: “-Duser.timezone=Europe/Stockholm”
TZ: “Europe/Stockholm”