openHAB2 - HomeKit - question about smarthome:homekit allowUnauthenticated true

Hi there,

just a quick qeustion about the setup of HomeKit, as I was able to successfully configure my items and add them to the homkit app on my ipad. However now I wonder if it is necessary to run the OSGi command

smarthome:homekit allowUnauthenticated true

everytime I restart openHAB2?

Is this required every time to allow access?
Is it possible to add this setting to eg. my services/homekit.cfg file?
Or should it be stored automatically (which doesn’t seem to happen in my system)?

Any hint is greatly appreciated!

Best regards

Did some more investigation the last days and found that I probably misunderstood the meaning of this setting.

It would be great if soneone is able to provide me a short explanation of this setting…

Getting Homekit to run I found that there seems to be a problem if the avahi-daemon is running on the machine at the same time!

Avahi-daemon binds itself to the udp port 5353 to allow for zeroconf network configuration and eg. name resolution.

I saw that openhab2 (the java process) binds to the same port. It looks like the openhab homekit is not announced properly if avahi-daemon is running. I had several issues seeing openhab on my iPad in the LAN.

After disabling avahi-daemon (systemctl disable avahi-daemon) on my raspberry I found openhab always listening on 5353/udp and I was able to see openhab any time on my ipad since then :slight_smile:

Is anybody able to confirm my findings? What was/is your experience about this?

Btw. I tried to pair my iPad with a fresh install of openhab and pairing was working perfectly even without setting the parameter (allowUnauthenticated) in OSGi.

allowUnauthenticated is just there for debugging. Your iPhone/iPad always authenticates.

As far as the UPNP advertisement goes, I can see how that would conflict with avahi. I actually don’t know how advertisements on different ports are handled. Maybe check if there’s a port configuration for avahi you can change?