openHAB2, KNX dimmer config

Hi

I am VERY new to openHAB so please be gentil :slight_smile:

I have a working openHAB 2.1.0 installation with the KNX binding and can turn my lights on and off. What I would now like to do is dim the lights - I think I understand the way to do it but cannot understand what my electricians have done so I have just tried everything and nothing is working - every time I have a dimmer line in my items file openHAB does not load the file.

I have the following information from the Electrition (I am using the kitchen light as an example):

Switch (Schalten) -> 1/1/1 value 1 bit
Dim (Dimmen) -> 1/2/1 value 4 bits
Return code switch (Rückmeldungen Schalten) -> 1/3/1 value 1 bit
Return value (Rückmeldung Wert) -> 1/4/1 value 1 Byte

The words in brackets are the German descriptions that I have in the documentation. Unfortunately the Electrition has gone out of business so I cannot contact them to ask what they have done.

Other than these values I do not have any documentation.

The examples in the documentation use percentages, I do not know how to add this to my command :slight_smile:

Could somebody maybe create the correct Dimmer line for me?

Thank you in advance
ursus

Hey Ursus,

try this one here in your items file (assuming knx is configure). I am missing an absolute dim-value.

Dimmer Licht_Kueche "Licht Küche" {autoupdate="true", knx="1/1/1+<1/3/1,1/2/1,<1/4/1"}

Kindly Björn

Hi Björn,

thank you very much - that has solved part of my problem :o)

I am not quite sure what you mean by “I am missing an absolute dim-value” - where could I find the value for you and what does it do?

I now have a dimmer and that actually dims the lights - yay! The dimmer and the switch are somehow at odds with one another now though. I can dim the lights and then turn them off with the switch, if I turn them off with the dimmer (by going all the way to the left) I cannot turn them on using the switch anymore - odd.

Maybe you could take a look at my settings? Here are the relevant lines:

Group Bedroom
Switch Bedroom_Switch “Bedroom Light” (Bedroom, Lighting) [“Lighting”] {knx=“1/1/4+1/3/4”}

Dimmer Bedroom_Dimmer “Bedroom Dimmer” (Bedroom, Lighting) [“Lighting”] {autoupdate=“true”, knx=“1/1/4+<1/3/4,1/2/4,<1/4/4”}

I see I am missing the autoupdate=true, is there anything else wrong?

Thank you again
Ursus

Hi Ursus,

my dimmer has a further group address for an absolute dim-value (e.g. 50%).
As the 1/3/4 Groupaddress is readonly I’d always write a “<” in front of it so that openhab only reads it.

Switch Bedroom_Switch “Bedroom Light” (Bedroom, Lighting) [“Lighting”] {knx=“1/1/4+<1/3/4”}

But not sure whether this solves your problem. Maybe one of the experts here could help you otherwise.

The autoupdate was a workaround (?) I found which avoids openhab to replicate KNX messages.

Björn

I only have the group addresses that I gave so I do not seem to have a absolute dim-value. Lets see if anyone chimes in. Thank you again for your help :smile:

Now I have to get my shades working :slight_smile: and some sort of persistence

Maybe not that odd …could it be that when you turn the light off by using the dimmer (brightness set to 0%), I would believe that the state is remembered. So what happens when you use the switch to turn the light on…? you basically re-set the brightness value to 0% (i.e no light). Could this be the case?

BR,
M

Martin, thank you for answering, sorry I only got around to replying now but I was out of the country for work.

I think that my system has a lot of errors in the KNX configuration. I am seeing device ids that are in the ETS config but do not do any communication at all. The documentation I received from the Electrition and what is actually being sent on the bus is not the same! I am a bit confused all in all.

To answer your question: yes, the system remembers the dimmed setting and when I press the switch the light goes to the last set value.

Does that help at all?

Hi Ursus,

I would not spend too munch time getting OpenHAB to work if you don’t have control over the basics (KNX configuration). I trust you already have ETS? If you do, then I believe you have to go through your KNX config and make the required changes or at least get an understanding of your KNX config. If you do not have ETS, I would consider getting it.

Martin

Thank you for your prompt answer - will update my KNX ASAP and try again :slight_smile: