OpenHab2, new lock from a new manufacturer

Any news Chris? Looking forward to testing it! :slight_smile:

I have this working with the dev branch of the binding for OH2. (See separate thread) Initially had some problems with battery running out, but now it seems to be working fine!

Do you have a link to the thread or binding? Can not find it.

Yes,

Thanks! I did download and deleted everything, but still "unknown"
Did you make a node.xml for idlock youself?

The zwave binding creates the xml-files when the device is initialized, nothing we should do ourselves. The id-lock is already in the device database so you should be good to go. What attributes are listed for idlock in the thing section in Habmin? Mine looks like this:


Have you configured a security key for the z-wave controller and included the lock successfully with secure inclusion?

Thanks for the response Olav. i have tried to delete it en include it again, but without sucess. Was you device unknow to start with and then after some time it was finished? I see this can happen according to the driver text for battery devices. Is there any else way to include it secure then regular?

How far is the zwave controller from the ID lock? Can you please take a picture of Z-wave network settings? :slight_smile:

It is strange that it still shows up as unknown. Are you sure you are running a recent zwave binding from the dev branch? It didn’t take too long before it showed up for me. Can you see if the xml was generated? The controller should be close (1 meter or closer maybe) to the lock when you include it. You should se a message in habmin that secure inclusion was successful.

If you are sure you are running the right binding version I would try to exclude the lock (enter exclude mode in habmin, hold lock key till the sound changes, then press 8…, just like including) Then do the inclusion process over again.

NB! You should change the encryption key and exclude and reinclude the lock if the key in the screenshot is your actual key! Keep it safe and don’t post it on the forums.

I am running this dev - org.openhab.binding.zwave-2.1.0-SNAPSHOT, lates i could find.

Have moved server to 1 meters from door, exlude and include, no errors and here are the logs.
2017-03-11 19:41:54.149 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:ffa895e5:node10’ to inbox.
2017-03-11 19:41:55.511 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 10: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.
2017-03-11 19:41:55.770 [ERROR] [alization.ZWaveNodeInitStageAdvancer] - NODE 10: SECURITY_INC State=COMPLETE

But i also get this after
2017-03-11 19:42:28.142 [ERROR] [alization.ZWaveNodeInitStageAdvancer] - NODE 10: SECURITY_INC State=FAILED

I have tried several times, and node.xml file is updated but just with the “unknow” information.

Can i do include without internet? Then i can try with 10cm apart.

And thanks for the heads up about the key, have generated a new one.

I have tried to include it 20 cm from the lock without internet, and it worked.

2017-03-12 09:50:58.359 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:ffa895e5:node4’ to inbox.
2017-03-12 09:50:58.659 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 4: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.
2017-03-12 09:50:59.131 [ERROR] [alization.ZWaveNodeInitStageAdvancer] - NODE 4: SECURITY_INC State=COMPLETE
2017-03-12 09:51:01.042 [INFO ] [ommandclass.ZWaveVersionCommandClass] - NODE 4: Command Class COMMAND_CLASS_BASIC has version 0!

But i cant controll it, is there any settings i need to do?
When i push the button i see this in the log

2017-03-12 11:05:03.327 [WARN ] [nal.converter.ZWaveDoorLockConverter] - NODE 4: Command class COMMAND_CLASS_DOOR_LOCK not found

Is it still an unknown device or recognized as idlock? Did you link an item to the door lock channel?

It was recognized as idlock after i restarted openhab again. But battery is also nan. I have auto on items so that was generated. The “sound” in the ID lock changed to “Twinkle twinkle little star” this has happend before also, think that is because of battery, so changed it (maybe this sequence was draining it last night)

Changed battery, still “marked as failed”, deleted it from things and added it again, now it is unknown and NODE 4: Is currently marked as failed by the controller!

Controller is 10 meters away with almost free line of sight, can this be the reason? Do i need to include it again from 20 cm you think?

One thing that is strange, still not genereted node.xml file.

Btw, using this version of driver:
2.1.0.201703050931, what are you using?

Any progress?
I’m a bit busy these days, so haven’t had time to reply to you.

Seems like the binding is ok then. Honestly I don’t know why it won’t work. When including you should be close, but afterwards it shouldn’t matter. When I first got it included everything was fine.

Maybe it hasn’t initialized properly. Missing xml would suggest this. What does the attribute section for the device say? It should look like the one I posted above. For me it took a little time, but not hours. If still problems and marked as failed it might be worth a try excluding and including again… I seem to remember trying a couple of times. (Also removing battery to be sure, but I’m not sure this is necessary) . You could try enabling debug logging and see if the log gives you any clue.

In karaf console: log:set DEBUG org.openhab.binding.zwave

If still problems maybe chris or some more excperienced user will have a clue. But a debug log would be necessary.

Nb!
Check the latest posts in the security branch thread about dead nodes and battery!

Interesting - I’m getting the unknown device problem with a Schlage BE469 lock. When I initially included it with the old 2.0.0 zwave binding, it was able to determine manufacturer and device info (but didn’t function). Now with the 2.1.0 binding, I can see the secure inclusion seems to have worked (Habmin shows “Using Security” green check), but the device is unknown.

Tried inclusion several times, with/without excluding, factory resets of one/both Z-stick and lock.

EDIT: Following a tip in another thread, after doing the first secure inclusion and seeing the lock show up as an unknown device, I deleted the lock Thing without excluding the lock from the stick, and re-ran the scan. This time it showed up as a known device and functioned correctly. Don’t know for sure if it was the thing delete without exclusion & rescan that made it work, or if it was just dumb luck on the 9th or 10th try. Hope this helps you here.

Also - @01av , you wrote:

Under OH2, with the 2.1.0 zwave binding, I did not need to configure a security key for my Aeotec Z-stick Gen5, it seems to have negotiated this automatically during secure inclusion.

One other note @tomhag - I also got the

Command class COMMAND_CLASS_DOOR_LOCK not found

error, when the inclusion was successful in non-secure mode. Successfully doing a secure inclusion with the 2.1.0 zwave binding solved that error for me.

Thanks for the feedback, it seems like i struggle with secure inclusion. I can include it, but secure inc = Failed. Almost giving up, no mather what i do i cant secure include it…

I believe you did this, but if not it would be worth a try, I did this a couple of times with success earlier on: Exclude the lock from the zwave network. Then remove all the batteries. Re-insert batteries after a minute or so and try inclusion again, making sure you have the controller really close (10-20cm or so).

Also make sure the oh system has settled and is not initializing other nodes at the same time, to be sure the secure inclusion can happen uninterrupted. ( At least I believe this would be necessary )