Openhab2 on Debian not starting

I just switched server, and installed Openhab2, following the Debian guide.

It installed without any errors, but when I try to start it, it just says this

root@Fiona:/home# service openhab2 start
[ ok ] Starting openHAB2 server: openhab2.

But it does not start. When looking in running processes, openhab isn’t running. When looking in the log directory, I only see the Readme.txt file, are there any other way I can see some log files or some more info about what is happening?

manual or apt? 2.1 Stable Release Build?

what is your java -version ?

I used the apt guide

java version "1.6.0_38"
OpenJDK Runtime Environment (IcedTea6 1.13.10) (6b38-1.13.10-1~deb7u1)
OpenJDK 64-Bit Server VM (build 23.25-b01, mixed mode)

hmm… old version of openJDK + OH2 = not a good mix :slight_smile:

I would:
(Oracle JDK 8 using apt)

Thank you! That worked, I didn’t even considered that to be a problem, I was more focused on why it wouldn’t tell me what was wrong.

1 Like

According to:
you need Java 8 u101 as a min. JRE or JDK is fine.
You had Java 6 u38 (that’s old)

you could have tried to start OH2 using debug (set OPENHAB_STARTMODE=debug in /etc/defaults/openhab2) and then systemctl start openhab2 to see if additional logs would appear.

Not 100% sure if this option is available in the 2.1 Release Build.
It is in the latest 2.2 Snapshot (Build #1000)

The snapshots should tell you if the Java version isn’t supported. However, this was a recent fix that wouldn’t be in the release build.

Whilst it’d be unnecessary for problems like this. That option is for systemd, which should be started with systemctl start openhab2.service. Again this is currently for snapshot builds only right now, but will be available for 2.2.

If using upstart or the etc/init.d/openhab2 script directly, then the OPENHAB_STARTMODE has no effect.

1 Like