openHAB2 on QNAP TS 412 - No connection to web server

  • Platform information:
    • Hardware: ARM Processor Marvel 6281 with 1,2 GHz and 256 MB RAM
    • OS: (latest QNAP firmware)
    • Java Runtime Environment: 1.8.0_65 (installed from QNAP APP Store)
    • openHAB version: 2.0.0-3
  • Issue of the topic: During installation I performed the following steps:

1. I download the QPKG from GitHub

2. I created a share called “openHAB2” with RW access for everybody

3. From the App Center I installed “JRE_ARM”

The insalled Version is

[/] # java -version
java version "1.8.0_65"
Java(TM) SE Embedded Runtime Environment (build 1.8.0_65-b17, headless)
Java HotSpot(TM) Embedded Client VM (build 25.65-b01, mixed mode)


[/] # echo $JAVA_HOME

So I think everything is OK with this installation.

4. I installed manually th QPKG over the APP Center (I also tried it over the ssh)

This is the result of the ssh installation:

[/share/Public] # sh openHAB_2.0.0-3.qpkg
Install QNAP package on TS-NAS...
9+0 records in
9+0 records out
1580+1 records in
1580+1 records out
openHAB  is already installed. Setup will now perform package upgrading. line 356: [: -lt: unary operator expected
Firmware check is fine.
Link service start/stop script:
Set QPKG information in /etc/config/qpkg.conf
* Note: JAVA_HOME=/usr/local/jre
[App Center] openHAB 2.0.0-3 has been installed in /share/MD0_DATA/.qpkg/openHAB successfully.
[App Center] openHAB enabled.

The openHAB icon is available on the QNAP home.

5. Start web interface
I have waited some minutes and then tried to open http://qnap:8090/ with Chrome but I got the Error ERR_CONNECTION_REFUSED

Some additional information:

  • The share openHAB2 is still empty

  • The environment variable OPENHAB_HOME is empty

  • I found the files for openHAB at /share/MD0_DATA/.qpkg/openHAB

  • When I restart openHAB with the console I get the following information

[/share/MD0_DATA/.qpkg/openHAB] # sh restart
stop: Ignoring predefined value for KARAF_HOME
stop: KARAF_ETC is not valid: /share/MD0_DATA/.qpkg/openHAB/distribution/userdata/etc
  • When I try to start the console I get the following message:
[/share/MD0_DATA/.qpkg/openHAB] # sh console
* Note: JAVA_HOME=/usr/local/jre
Launching the openHAB runtime...
karaf: KARAF_ETC is not valid: /share/MD0_DATA/.qpkg/openHAB/distribution/userdata/etc

I don’t know what I am doing wrong. Does anybody have an idea?