OpenHAB2 on Windows Server - system error 1067 has occurred

I’m an absolute beginner with openHAB - sorry, if make silly mistakes.
I have a Windows Server 2008r2 running and try to install openHAB 2, following the advice given by
I also installed JAVA (tried both jre and jdk, and set the %JAVA_HOME% to the pathes as system variable).
When typing "net start “openHAB2"” , about 20 dots are comming, and the information "system error 1067 has occurred ".
The computer managemet shown openHAB2 as a service, but it also doesn’t start.

What would you recommed to do?
Thanks! Philipp

I have also placed the Java-directory below the \openHAB2-directory to avoid the blanks in the path name. Didn’t change anything…
What can I do?.

What version of Java are you using?

First I used jre1.8.0_161, then, after jdk was recommended, jdk-9.0.4

Uninstall both. Make sure install JDK version 8 series. Make sure you put java_home path in Enviromental Variables

Hello KidSquid,
thanks for your help!
Done, restarted computer.
Didn’t help:

Do you have any other ideas?

I believe 1067 is related to permissions. Make sure the user id under which you run the service has access to any required directories and files and is allowed network access.

Just reread your first post. Your trying to start OH as a Windows service. What happens when you just click on the batch file (start.bat) to start OH and not run it as a service, does it run that way?

Concerning the permissions: the server is placed in the basement and I’m controlling it by Remote desktop as a administrator. I’m also always starting the command prompt with “run as admin”.
When staring start. bat this happens:

Looks okay, doesn’t it?
Thank you

Have you change the C:\openHAB2\userdata\etc\openHAB2-wrapper.conf as described here?

Yes, that’s what OpenHab looks like when you start it via the batch file. So we know that the application is running.

The error you are receiving is due to trying to run OH as a service and as others have mentioned it may be due to a permission/security issue.

Have you made sure you followed the instructions for running as a service that are posted here:

If you had never started OH before that could have been part of the issue.


Hello, I think I’ve found my mistake.
I first tried to install from a different folder and this folder is still shown in the Services as “Path to executable”:
It is not possible to install the service again, as it already exists.
How do I delete this service to install it again?
Thanks for your help and sorry for my mistakes

Go into the registry. (Start --> run… --> regedit). Search for “openHAB2” (Service) and then change the path to your executable.

1 Like

Thank you all for your help and your patience.
Its working now!
Now I have to learn how to bind homematic IP and Alexa

I realize this is an older post, but I went thru this same error troubleshooting and finally resolved it.

  1. Make sure you’re doing this running as Administrator.
  2. After you make the updated conf file, make sure your directory path and syntax is correct. I found I had a “/” at the end of my directory path
  3. I received a 1067 after it said the service was installed, but yet it wouldn’t start. To delete the service - SC DELETE openHAB2. This removed it and I was able to build the service with the correct path.
1 Like

Hi all, I’m also a newbie, so please forgive any stupid questions! I’m facing a very similar situation.

I followed the description from here step by step. When trying to start the service, I got system error 1067.

The installed service points to the path C:\openHAB2\userdata\bin\openHAB2-wrapper.exe -s C:\openHAB2\userdata\etc\openHAB2-wrapper.conf - is this correct? If I try to execute this command manually (from an elevated shell, of course), I get:

PS C:\openHAB2> C:\openHAB2\userdata\bin\openHAB2-wrapper.exe -s C:\openHAB2\userdata\etc\openHAB2-wrapper.conf
Attempting to start openHAB2 as an NT service.

Calling StartServiceCtrlDispatcher...please wait.

StartServiceControlDispatcher failed!

For help, type

C:\openHAB2\userdata\bin\openHAB2-wrapper.exe /?

PS C:\openHAB2> C:\openHAB2\userdata\bin\openHAB2-wrapper.exe /?
FATAL  | wrapper  | Unable to open configuration file. C:\?
PS C:\openHAB2>

Can you give me any pointer how to solve the problem? Thanks in advance!

(The following should not be a problem, should it?


Hey LinqLover, did you manage to resolve this?