Openhab2 unreachable after clear-cache

Hi there,

I need to reach out to the community for the following issue:
I had some problems with parameters in my openhab2 installation not functioning properly, so I (mistakenly) thought it would help to clear the cache via openhab-cli stop / clear-cache / start. Unfortunately this operation left my openhab inaccessible via the iOS app and the http-port. PaperUI is gone :frowning:

openhab is up and running as a service:

 pi@raspberrypi:/var/log/openhab2 $ sudo service openhab2 status
● openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2020-11-22 12:27:09 CET; 22min ago
 Main PID: 3606 (java)
    Tasks: 22 (limit: 2063)
   CGroup: /system.slice/openhab2.service
           └─3606 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab.runtime=/usr/share/openhab2/runtime -Dopenhab.u

Nov 22 12:27:09 raspberrypi systemd[1]: Started openHAB 2 - empowering the smart home.

Hope to get assistance with this… Found some other threads regarding the clear-cache command bricking openhab, but so far nothing that saved my installation.

Kind regards,


Have you waited upt ot 40 minutes after the restart of openhab to let the UI come up again ?
Any messages in the openhab.log file ( /var/log/openhab/openhab.log ) that may give a hint ?

Nothing changed within five hours. openhab still can not be reached via http. Also there were no more log-entries since this morning despite the service still running… I wonder if it is something with the owner of the process. clear-cache was running with sudo, causing some problems with inaccessible files (chmod 777 solved the issue). Openhab however is running from user/group openhab.

There is an error message in Microsoft visual studio code:

Error: connect ECONNREFUSED
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1134:16) {
syscall: ‘connect’,
address: ‘’,
port: 8081
8081 is my http-port for openhab, 8080 is used for unifi.

try if this fix the problem:

sudo openhab-cli reset-ownership

Hi Wolfgang,

Thanks a lot for the hint!
Problem solved :smiley: :smiley: :smiley:

Kind regards,

1 Like