openHab2 Xiaomi Binding, not working


(Augis) #1

Hello, my xiaomi gateway doesn’t seem to receive commands from paper ui or basic ui. It shows online together with my temperature sensor, however none of them react to my commands.

my xiaomi.things

Bridge mihome:bridge:7811dcb90415 "Xiaomi Gateway" [ serialNumber="7811dcb90415", ipAddress="2.2.2.64", port=9898, key="kmiqg2nmjdmg933f", pollingInterval=6000 ] {
    Thing mihome:gateway:7811dcb90415 "Xiaomi Mi Smart Home Gateway" [itemId="7811dcb90415"]
    Thing mihome:sensor_ht:158d0001f41574 "Xiaomi Temperature Sensor" [itemId="158d0001f41574"]
}

if i understand correct these are the variables translated :

kmiqg2nmjdmg933f - dev key
78:11:DC:B9:04:15 - serialnumber
158d0001f41574 - sensor id
2.2.2.64 - ip

Any help is appreciated.

The : in the serialnumber are removed because it doesn’t go like that :smiley:


(Marcus K.) #2

did you tried to add the things using PaperUI or HABmin?


(Augis) #3

Yes.


(Augis) #4

2018-05-02 19:40:25.464 [INFO ] [el.core.internal.ModelRepositoryImpl] - Validation issues found in configuration model ‘xiaomi.things’, using it anyway:
Provide a thing type ID and a thing ID in this format:

Provide a thing type ID and a thing ID in this format:


(Augis) #5

Solved, I needed to update my openHab2 installiaton. But now I have another issue I don’t seem to be able to get them to auto update.