Openhab3 and Conbee II - Phoscon Thing Communication error

I use a completely neu setup of oh3.0 on Raspberry an integrated the Conbee stick.
Oh3 shows me a deconz thing, which i connected and found all zigbee devices.
But oh3 continuosly discovers a phoscon thing as well. When i cretae the thing, it goes pending configuration. I enabel the App connection in Phoscon app and oh3 gets the apikey and sets th phsocon thing online. Up to now, all looks fine.

But when i want to save the thing, oj3 reports a Communication-Error : “Destroyed container cannot be restarted” and sets the state of the phoscon thing to Offline.

As all my devices are ok using the deconz thing - i am unsure, why i need the phsocon thing at all?
But even when i ignore the phoscon thing in inbox, it always pops up again in Inbox.

So can anybody tell me, why i should install the phoscon thing or how i can get rid of ot in Inbox…
Thanks in advance.

Did you create the deconz brigde manually?

I don´t think so, but i remember, that i tried several times. The only error that probably happend, was that i installed the bride before my rasperry had deconz installed an running.
So - i installed the Binding when i setup oh3 - then wanted to install the deconz thing, but realized that i missed deconz. so i istanneld deconz and retried (with the existing apikey of oh2), that did not work, i installed a new apikey , connect it and installed all things discovered

I am on OH2. Created a thing file manually for the phoscon-gw / bridge.
The automatic discovered thing ( phoscon-gw ) pops up in the Paper-UI.
I am just ignoring it.

If the deconz thing was created before the deconz software was running, you created the things manually. That‘s the reason why you find a deconz bridge in discovery. You can either delete your own bridge, accept the discovery result and change all things to that new bridge or just ignore the one in the inbox. It‘s the same but openhab cannot automatically detect that.

i played araound deleting things and items on the deconz, restarting OH, deinstalled the binding and reinstalled it again - at one time i had deconz and phoscon thing online , but then i got most of the devices behing deconz twice and regularely discovered as new things - the same device tih the same deconz device ids was discovered twice as new thing in the same scan.

At the end i lost hope to fix it, so i decided to set back the system completely, startung new with a image flash of openhabian. Maybe de second try works better…

And yes it did: Finally it looks like you get two things for a conbee II - one named phosocn and one deconz.
You choose either of them, connect it requesting an api key (and put appropriate state on phoscon/deconz side…) . When the secong thing is discovered - create it as well as thing, and disable it .
So you have now either phoscon thing online and deconz thing disabled or vice versa - deconz thing online and phosocn thing disabled.
If you switch disabled states between things -> then you have all ligths and sensors doubled in openhab, half of them gone/offline/error.

Actually I had also a problem with the deconz bridge. For now solved with a work around. Steps taken:

  • installed OH3 with openhabian
  • set up the deconz bridge (auto discovery) towards a separate raspberry (my OH2 server)
  • discover all the things
  • after setting up the deconz application on the OH3 server config the bridge towards the IP of the OH3 server
  • ensured working properly and deleted the deconz from the OH2 server
  • not sure when, but in some point noticed the bridge stopped working with the error: Communication-Error : “Destroyed container cannot be restarted”
  • reset the bridge again to the OH3 IP, but after 1-2 minutes same error. Watching the bridge settings it hops for short time back to the old OH2 settings


  • restart OH3 server
  • delete Bridge and auto discover again (did discover the OH3 IP automatically)

But the same error keeps popping back. Finally configured a manual bridge and redirected all things towards this new bridge.
Everything works fine now, so no urgency to do something. But if required I can provide some additional information or steps. Or this info might help others with the same problem.

@lampy Hi Gerwin,
I am also having problems with the integration of he deCONZ Bridge.
My setup is somewhat different in that i am using a VM for openHAB3. But in principle it should be the same as a straight install on RPi.

I use a VM on Proxmox and Ubuntu Desktop as the VM OS. I installed the deCONZ App together with openhabian on this VM. That seems to work, because i can see my zigbee network in the deCONZ App.

Next i started the Phoscon App in the browser and i see my Zigbee devices also there.
In the Phoscon App (browser) i went to Settings::Gateway::Advanced in order to start the Authentication process,
Openhabian discovered the “Phoscon GW (” and when i press Authentcate in the Phoscon App the Api Key is transfered to the openhabian Phoscon GW settings.
But when i save this result i get:

Any idea what i am missing with these steps?

Try latest snapshot of the binding.

@J-N-K Hi Jan, that worked!
Thank you for your suggestion!