OpenHAB3 Somfy shutter (URTS II)

Hi guys / ladies,
I cold manage to get my Somfy shutters working under openHAB2. Then I decided to move to OpenHAB3 (did not backup the config…) and I can’t get it working again.
I did all the necessary RFXManager dance and that part works.
My local transmitter is a RFXtrx433XL and I have all the udev rules to have it under /dev/RFXtrx433XL.

Could some please help me from there? I have my shutters channels (“200207.X”), but can’t find where to give in as I can only use one digit as channel in the config :frowning:

Thanks a lot!
Benjamin

It’s a long time since I set mine up and as far as I recall, there was no problem moving them to OH3 but here is the Thing definition, in case it helps:
‘’’
Thing rfy KitchenBlind “Kitchen Door Blind” @ “Kitchen” [ deviceId=“66051.1” , subType=“RFY”]
Thing rfy KitchenWindowBlind “Kitchen Window Blind” @ “Kitchen” [ deviceId=“66051.2” , subType=“RFY” ]
‘’’

Barny,
thanks a lot for your help, unfortunately I’m still at the “click / GUI” phase so I don’t really know how to use your suggestion :sweat_smile:
Is there any updated toturial you’d know about?
Benjamin

So you setup the Bridge as a RFXCOM USB Transceiver Thing referencing serial port, then you create a new thing of type RFXCOM Rfy Actuator, referencing the bridge then in that config you add the channel.

I’m not 100% sure if mine uses URTS II but thats how I do my external Somfy blinds.

NicGray,
thanks for your help here.
I started up using the Somfy URTS II binding, but it seems you use the RFXCOM binding. I took a look at that but there are tons of config I need to provide so I’m left here with even mire questions.
I tried to mix and connect the “URTS II” USB transciever I setup (and that comes online) with the RFXCOM Rfy Actuator, but I can’t add my “URTS II” as bridge :frowning:

I feel like the “URTS II” solution might work, but I can only enter 1 char when I have to provide the channel, and I’d need to enter 6…

Any clue?
Benjamin

I use files because I find the results more reliable but they show up in the UI as though I configured them there.

This is the Thing for the blind:

If you create that, it should have a channel called “Shutter”, link that to a RollerShutter type item.

If you put the blind into learning mode and use the item as though it were the remote, the blind should pair with it.

Barney,

I seriously appreciate the effort you put in helping me, but I don’t get it (witch is super frustrating as I got it working on openHAB 2 :frowning: ).

I have my RFXCOM RFXtrx433XL box, and it’s paired with my 3 rollershutters (I know because they were before, and because the windows app can still pilot them when I put the box to my laptop)

So if I get you right, the first step wold be to declare the “USB transmitter” as an RFXCOM USB Transceiver, right?

I just add the local serial port config (/dev/RFXtrx433XL - I have local udev rule for that), then I set it to 433.92MHz, the thing is online, I’m happy.

I then create an RFXCOM:RFY thing, RFY as sub-type, and add 200207.1 as device ID (this could be the issue).

Should I then link the Shutter to a new RollerShutter (how do I create one, then?) or to an existing one? What should I have here?

This is where I’m stuck :frowning:

Any help more than welcome :slight_smile:

Benjamin

You’re testing my memory now; it’s 4 years since I set this up so I may have some of the details wrong.

As I recall, the RfxCom settings are mostly for receiving; it can transmit anything but needs to know what types of signal it is listening for. For that reason, mine doesn’t listen for the Somfy remote because, as you say, it would need to switch frequencies to do that, which would disrupt listening for standard 433MHz remotes.

The device ID needs to match the one your blind is expecting, otherwise it ignores it, assuming it’s for another blind. I found the easiest way to do this was not to try to and mimic a known ID, just to invent one and then pair the blind with it.

You could happily copy the one I used (assuming you don’t live next door). Effectively, that turns the RfxCom into a remote with a defined ID. Now all you need to do is teach the blind to listen for that remote by using the standard pairing process but instead of using a physical remote, you just trigger the Item in OpenHAB that is linked to the RfxCom RFY Thing.

If you already have the Device ID from previously/windows app then just substitute the one from my example in the appropriate ones.

Each Thing needs to be linked to a RollerShutter item. You can do that by selecting the Thing, choose the Channel tab and find the “Shutter” channel, then click on the channel and choose the little green + “Add link to item” icon.

Barney,
I just can’t my current device ID to work, so I’ll try to pair the again. Still I struggle on how to do this without the “program” button from the remote?
Thanks!

Barney,
I checked it all again and it turned out I just messed my HEX => DEC conversion. :man_facepalming:

Thanks for your kindness and patience :+1:

Benjamin