OpenHAB3 - Tuya Lampe | Tuya Lamp - Tasmota

Hallo Comunity,
heute melde ich mich mal mit einem anderen Thema und hoffen mal, das es hier ein paar Personen gibt, die mir weiter helfen könnten.
Ich habe mir eine Briloner Leute gekauft, welche ein Tuya-Modul besitzt.
Um genauer zu sein, sitzt folgendes Modul drin: Meko LED Driver MKP060C1450BLTG-1
Das Problem mit OpenHAB ist nun, dass die Leuchte zwar im WLAN ist, aber nicht erkannt wird.
=> Mein Raspberry Pi 4B stellt ein WLAN-HotSpot zur Verfügung, an dem sich alle meine Geräte welche per WLAN verbunden werden müssen melden. Die Geräte haben dadurch auch keinen Zugriff ins Internet.
Ich habe im Netz Anleitungen gefunden, wie man mit Hilfe eines Raspberry Pis und einem Script die Lampe mit Tasmota flashen kann.
Leider funktioniert das Script nicht mehr.
Die Leuchte verbindet sich zwar mit dem WLAN, der Flashvorgang geht aber nicht.

  • Ich mach das ganze mit einem Raspberry Pi 3B+
  • Ich muss die Leuchte 1sec EIN, dann 4sec aus, dann 1sec EIN, dann 4Sec aus und dann wieder einschalten, damit sie blinkt (Neues Schaltmuster wie mir der Hersteller mitgeteilt hat)

Ich gehe mal davon aus, dass meine Lampe die neuste Firmware besitzt, wo es scheinbar gerade ein paar Probleme mit dem flashen gibt.
Da ich kein ESP-Board da hätte, um die Leuchte anderweitig zu falshen, ist nun die Frage, ob es aktuell überhaupt eine Möglichkeit gibt, die Lampe mit Tasmota zu versorgen?

Hello Comunity,
today I’m reporting with another topic and hope that there are a few people here who could help me.
I bought a Briloner lamp, which has a Tuya module.
To be more precise, the following module sits in it: Meko LED Driver MKP060C1450BLTG-1.
The problem with OpenHAB now is that the light is in the WLAN, but it is not recognized.
=> My Raspberry Pi 4B provides a WLAN HotSpot to which all my devices which need to be connected via WLAN report. The devices have thereby also no access to the Internet.
I found instructions on the net how to flash the lamp with Tasmota using a Raspberry Pi and a script.
Unfortunately the script does not work anymore.
The lamp connects to the WLAN, but the flashing process does not work.

  • I do the whole thing with a Raspberry Pi 3B+.
  • I have to turn the light ON for 1sec, then off for 4sec, then ON for 1sec, then off for 4sec, then on again for it to flash (New switching pattern as the manufacturer told me).

I’m going to assume my light has the latest firmware, where there seems to be some flashing issues right now.
Since I would not have an ESP board there to falshen the lamp otherwise, the question is now whether there is currently any possibility at all to supply the lamp with Tasmota?

Rather than assuming, there’s a discussion on the Tuya-convert Github that tells you exactly what to look for.

As stated on the Tasmota website, you can also use a serial-to-USB cable. But if your actual question is, “can I do this without connecting directly to the SoC”, then the answer is no.

It’s also possible that this lamp has a RealTek chip, in which case Tasmota isn’t compatible at all. However, if you managed to connect to the module using Tuya-convert then it’s probably just the firmware.

I have already found the article on GitHub and read through it once.
Unfortunately, I do not have a serial-to-USB cable here to flash the whole thing directly and just for the one lamp I do not want to buy one now.
So important and urgent is not then. Would have been nice only if it would work (directly).

Whether it is in the end only at the firmware, is currently questionable, because I could connect the lamp only with the HotSpot of the Raspberry Pi.
The Tuya-Converter Script has not done anything yet.
In the log I only see that devices (my smartphone and the lamp) had connected to the HotSpot, nothing else happened.

There are tutorials in the community to connect Tuya devices to openHAB without flashing, but you don’t gain local control of them. I haven’t tried, as it’s more effort than I want to put in for my one unflashable Tuya device.

FYI, I tried using a serial-to-USB cable, more out of interest than anything else. However, I couldn’t get it to flash, and in the process remembered that I don’t like working on small electronics. :wink:

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.