openHabian 1.6.4 serial port issue

Yesterday, I downloaded openHABian 1.6.4 to try on my RaspberryPi 3/Razberry setup, and encountered a problem the Zwave Controller appearing to be offline. ‘No probs’ I thought, I just need to run openHAbian-config and configure the serial port. I did this, and rebooted, but the ZWave controller was still offline. Tried a couple more times thorough the config gui to no avail. In the end I had to manually edit the ‘config.txt’ file to add the following lines:


Just thought I’d highlight the problem in case anybody else was stuck in this loop.

Make sure the binding is using the RIGHT port. you can check your dmesg to verify.


You may also need to disable serial console in openHabian-config if it’s using same GPIO pins.

Which is enabled by default so you (OP) probably forgot to do that ?

Hi Markus. No, I did both in openHabian-config, hence me starting this thread. I did question my sanity a couple of times, and re-ran the openHabian-config scripts, but same result. I just thought that I’d highlight my issues in case somebody else thought that they were going mad too :slight_smile:

Can you please open a Github issue and provide a config run that exhibits the problem with debugmode=maximum enabled in openhabian.conf ?

the same for me. i have update a 3.0.1 to 3.0.2 and serial port it’s disconnected for openhab but it’s ok. i ve made a fresh install with 3.0.2 and same problem, serial it’s disconnected. Downgrade to 3.0.1. and now it’s ok, zwave stick and arduino are see by openhab.

it’s not ok for me, the file it’s in /boot/config.txt, right?

Yes, just add it at the end of the file. Then reboot.

there is something strange in openhab serial after update to 3.0.2. it’s impossible to have zwave working and the log say
2021-05-09 14:44:30.164 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null

2021-05-09 14:44:30.484 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null

this is a fresh istallation of openhabian and i have an arduino (that 's ok) and a zwave stick.
if i plug zwave stick in other raspberry with openhabian there aren’t problems.

Is one of the Raspberries a RPi4? They have USB3 ports that do not work well with some older sticks that violate the USB standard. They need to be plugged in to a USB2 hub to the Pi4.

Bruce, it’s a rasp 3b+. but i have another openhab running on a rasp 4 and i have no problem with z stick.

1 Like

I am running the latest snapshot in Docker on a 3B+ with no issues.

i don’t know what kind of problem can made this.
this is my terminal

 openhabian@openhabian:~ $ lsusb
Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 005: ID 2341:0042 Arduino SA Mega 2560 R3 (CDC ACM)
Bus 001 Device 006: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

but openhabian say that zwave it’s offline. the port it’s correct.

What is the output of dmesg | grep tty ? That shows the devices recognized by the OS. I have a HUSBZB1 stick which is a Zigbee & Z-Wave north American stick. In my cacase /dev/ttyUSB0 is Z-Wave and /dev/ttyUSB1 is Zigbee.

pi@raspberrypi:~ $ lsusb
Bus 001 Device 004: ID 10c4:8a2a Cygnal Integrated Products, Inc.
Bus 001 Device 005: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@raspberrypi:~ $ dmesg | grep tty
[    0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=0 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  console=ttyS0,115200 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline rootwait
[    0.001174] printk: console [tty1] enabled
[    3.141296] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 114, base_baud = 0) is a PL011 rev2
[    7.475260] usb 1-1.1.3: cp210x converter now attached to ttyUSB0
[    7.482694] usb 1-1.1.3: cp210x converter now attached to ttyUSB1

this is the output:

openhabian@openhabian:~ $ dmesg | grep tty
[    0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 snd_bcm2835          .enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1  smsc95xx.macaddr=DC:A6:32:99:2F          :8A vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000  console=ttyAMA0,11520          0 console=tty1 root=PARTUUID=418fab16-02 rootfstype=ext4 elevator=deadline fsck.          repair=yes rootwait
[    0.001801] printk: console [tty1] enabled
[    1.436952] fe201000.serial: ttyAMA0 at MMIO 0xfe201000 (irq = 36, base_baud           = 0) is a PL011 rev2
[    2.667091] printk: console [ttyAMA0] enabled
[    2.688092] fe215040.serial: ttyS0 at MMIO 0xfe215040 (irq = 37, base_baud =           62500000) is a 16550
[    4.568538] systemd[1]: Created slice system-serial\x2dgetty.slice.
[    4.576454] systemd[1]: Created slice system-getty.slice.
[    6.334624] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device
[    6.338341] cdc_acm 1-1.3.1:1.0: ttyACM1: USB ACM device

i ve also modified the serial rules for persistence
sudo nano /etc/udev/rules.d/99-usb-serial.rules

SUBSYSTEM=="tty", ATTRS{idVendor}=="2341", ATTRS{idProduct}=="0042", SYMLINK+="ttyUSB99"
SUBSYSTEM=="tty", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", SYMLINK+="ttyUSB97"

but for 3 years no problem.

In all my years working with Unix and Linux systems I have never needed to use device aliases. I do not think the serial rules normally need customization any more. The serial addon automatically detects available ports.

excuse but i don’t understad, sorry, the serial rules as necessary beacouse at the restart of raspberry one device can change the port. or not.
the documentation says:

* When using more than one USB-Serial converters, it may happen that the `/dev/ttyUSB0` device is named `/dev/ttyUSB1` after a reboot. To prevent this problem, alias names can be assigned to serial devices by adding them to `/etc/udev/rules.d/99-com.rules`. Example:

SUBSYSTEM==“tty”, ATTRS{idVendor}==“0403”, ATTRS{idProduct}==“6001”, ATTRS{serial}==“AE01F0PD”, SYMLINK+=“ttyMySensors”
SUBSYSTEM==“tty”, ATTRS{idVendor}==“10c4”, ATTRS{idProduct}==“ea60”, ATTRS{serial}==“0001”, SYMLINK+=“ttyCulStick”

i don’t have other costumization. i’m really worried, i don’t know now how can resolve my issues… i have try to use socat but the port of socat it’s unavailable for openhab but it’s available in /dev.
thank you

i ve set the log of zwave to TRACE and this is the log.

2021-05-09 22:01:21.272 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - Creating ZWave discovery service for zwave:serial_zstick:zwaveery with scan time of 60

2021-05-09 22:01:21.274 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - ZWave discovery: Active zwave:serial_zstick:zwaveery

2021-05-09 22:01:21.276 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null

2021-05-09 22:01:21.395 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Initializing ZWave serial controller.

2021-05-09 22:01:21.397 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Initializing ZWave Controller zwave:serial_zstick:zwaveery.

2021-05-09 22:01:21.406 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - Creating ZWave discovery service for zwave:serial_zstick:d4c062c77c with scan time of 60

2021-05-09 22:01:21.408 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - ZWave discovery: Active zwave:serial_zstick:d4c062c77c

2021-05-09 22:01:21.411 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null

2021-05-09 22:01:21.556 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Initializing ZWave serial controller.

2021-05-09 22:01:21.557 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Initializing ZWave Controller zwave:serial_zstick:d4c062c77c.

2021-05-09 22:01:21.787 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node5.

2021-05-09 22:01:21.800 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node27.

2021-05-09 22:01:21.810 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node8.

2021-05-09 22:01:21.823 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node17.

2021-05-09 22:01:21.824 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node16.

2021-05-09 22:01:21.832 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node3.

2021-05-09 22:01:21.867 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node4.

2021-05-09 22:01:21.872 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node28.

2021-05-09 22:01:21.874 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node13.

2021-05-09 22:01:21.909 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node9.

2021-05-09 22:01:21.921 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node14.

2021-05-09 22:01:21.934 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node29.

2021-05-09 22:01:21.936 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node30.

2021-05-09 22:01:21.965 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node71.

2021-05-09 22:01:21.967 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node22.

2021-05-09 22:01:21.986 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node20.

2021-05-09 22:01:21.993 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node24.

2021-05-09 22:01:22.003 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:d4c062c77c:node23.

2021-05-09 22:01:26.589 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyUSB97

i’ve solved my issue removing ipcamera binding that stop zwave at startup.

1 Like