Openhabian after update questions

openHAB 2.5.11-1 (Release Build)
Raspberry PI
Bindings: MQTT , Zwave, Astro, mapdb, influxdb, network, NTP

I just updated to the 2.5.11-1. Seems most everything is working so far. But some questions…

When I booted after the upgrade this was in the log:

[WARN ] [ab.binding.mail.internal.SMTPHandler] - Sending the email to the following server failed :

2021-01-26 13:13:56.793 [WARN ] [ab.binding.mail.internal.SMTPHandler] - com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.0 Must issue a STARTTLS command first. k64sm14751023qkc.110 - gsmtp

There was also a note that flew bye during the update about changing something to STARTTLS

Not sure how to proceed on this.

When I login to the OH Pi I get this noted:

2021-01-26 13:13:50,336: FireMotD: Info: No FireMotD ExportFile detected. Please generate with “sudo .\FireMotD -S”

Again, not sure what to do and more importantly why.

And my Inbox in Paper UI has these:

NTP does seem to be working as does the Astro Binding.

Just getting back to tinkering with the system after 6 months…no need to since it has worked fine.
So need to get my mind around things again.
Since I want to add a Zwave device to my network in a few days, I figured I’d get things working before trying H3…

So getting reoriented.

see the documentation Mail - Bindings | openHAB
Sounds like your configuration for the security is set to PLAIN. You should set it to STARTTLS to not submit the password in plaintext.

Depending on how you upgraded there will be an upgrade.log file where you can go back and see that stuff that flew by.

This is from FireMotD which is not part of openHAB. It is what generates that table of machine statistics when you first log in. Sometimes it gets messed up. You can usually fix it by running that command it tells you to run from the FireMotD folder (/opt/firemotd perhaps?).

By default Astro will “discover” a sub and moon thing based on the lat/long configured in settings. I assume something similar is going on with NTP, it discovered an NTP service on your network.

mail thing is:

Thing mail:smtp:Gmail [ hostname=“”, sender="", security=“TLS”, username="", password=“hidden text” ]

I used openhabian-config, where does the update.log end up? Nothing with that name in /var/log

Hmm…it doesn’t appear FireMotD exists. Executing that command get no command found error, whereis says nothing, and apropos finds nothing.

So I can safely ignore the Astro things since I don’t use them?

network.things points to
I don’t think I have anything providing NTP on my side of my firewall…

The documentation states:

The security parameter defines the transport security and can be set to PLAIN (default), STARTTLS or SSL (for implicit SSL/TLS). The port parameter is used to change the default ports for the SMTP server. Default ports are 25 (for PLAIN and STARTTLS) and 465 (for SSL).

So it shouldn’t be port 25 that is mentioned in the log, right ?
What if you use the keyword SSL instead of TLS ? Does it work then ?

Yes, indeed it does. But, I have no idea why with the setting as TLS the log mentions port 25.
I changed the setting to STARTTLS and it now appears to be working.


1 Like

Could be a bug or TLS is not an allowed keyword. Although then I would expect to see an error message in case a wrong string is being used.

systemctl start firemotd.service

If systemctl list-timers should show the firemotd timer to be N/A, edit these two files to match mine:

[21:52:24] root@openhab:/home/openhabian# cat /etc/systemd/system/firemotd.service
Description=Periodic FireMotD stats regeneration

ExecStart=/usr/local/bin/FireMotD -S -D all &> /dev/null

[21:53:13] root@openhab:/home/openhabian# cat /etc/systemd/system/firemotd.timer
Description=Daily generation of FireMotD stats

OnCalendar=*-*-* 00:00

1 Like

Because the SMTP connection starts on that port. It is plaintext per default then starts encrypting after STARTTLS is issued but the port stays to be 25.