[openhabian] All Things uninitialized after reboot/update

After i updated all packages and rebooted by RPi4 all of my things are “UNINITIALIZED”

Thats why i can’t send any commands anymore → Nothing is working

I already backed up my whole SD Card

Can someone tell me what to do, without breaking my whole system?

Here is what i did:

  1. Tried to update pihole (running on my openhabian) with error
  2. Tried to update all packages with apt-get upgrade and got something like “/usr/bin/dpkg returned an error code (2)” that one file was missing
  3. Tried to update everything from openhab-config → Also error
  4. Tried to reboot via console → Got some errors during boot that i went into emergency mode
  5. After carefully rebooting i could update everything in my system properly (i dont know why)
  6. After updating everything i rebooted several times → Pi is running and no updates pending
    My openHAB 3 UI is showing up but it seems that two of my images are broken
    All things are UNINITIALIZED

Im pretty sure that this sounds like a broken SD card but not long ago i bought new ones (for openhabian and amanda-backup via usb) → Thats why i hope/think that these can not be broken again

Sorry for my bad documentation → It was a hectic day and i hope someone can give me a good direction where to go

I think i should have a fully working SD Image left from a previous backup to which i can return
I now have made one at the current state

  version: 3.2.0.M3
  buildString: Milestone Build
locale: en-GB
  configFolder: /etc/openhab
  userdataFolder: /var/lib/openhab
  logFolder: /var/log/openhab
  javaVersion: 11.0.13
  javaVendor: Azul Systems, Inc.
  javaVendorVersion: Zulu11.52+13-CA
  osName: Linux
  osVersion: 5.10.63-v7+
  osArchitecture: arm
  availableProcessors: 4
  freeMemory: 100547328
  totalMemory: 194772992
bindings: []
    ios: false
    android: false
    androidChrome: false
    desktop: true
    iphone: false
    ipod: false
    ipad: false
    edge: false
    ie: false
    firefox: false
    macos: false
    windows: false
    cordova: false
    phonegap: false
    electron: false
    nwjs: false
    webView: false
    webview: false
    standalone: false
    pixelRatio: 1
    prefersColorScheme: dark
  isSecureContext: false
  locationbarVisible: true
  menubarVisible: true
    cookieEnabled: true
    deviceMemory: N/A
    hardwareConcurrency: 8
    language: en-US
      - en-US
    onLine: true
    platform: Linux x86_64
    width: 3440
    height: 1440
    colorDepth: 24
    touch: false
    pointerEvents: true
    observer: true
    passiveListener: true
    gestures: false
    intersectionObserver: true
    dark: dark
    filled: true
    pageTransitionAnimation: default
    bars: light
    homeNavbar: default
    homeBackground: default
    expandableCardAnimation: default
  userAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like
    Gecko) Chrome/87.0.4280.141 Safari/537.36
timestamp: 2021-10-29T11:08:27.701Z

Do the things all belong to the same binding (e.G. Z-Wave).
Maybe the bridge (e.b. Z-Wave controller, Spotify Bridge, …) is having some problem and thus the things which are using this bridge are uninitialized…

1 Like


Mqtt, openweather, Google Chromecast …

Everything uninitialised no matter what
Frontal tells me the stuff is sent, but the devices are not listed

If no-one comes with a better solution I have to flash back

You are mixing/confusing various stuff as potential causes, starting right with the thread title (uninitialized things are an openHAB thing - that is unrelated to openHABian) and continue to confuse readers throughout your post. You also (against the recommendation) installed stuff on top of your OH box yourself without explaining what exactly you modified and what else you did to the system and now you expect someone (not yourself) to know what that has caused and how to fix it.
Expecting that is not ok. Noone can help when you are not providing any error messages and reasonable logs. You did not even provide a minimum of detail about your system or any attempt at diagnosing your issue. It’s a request at people to waste their time by wildly guessing at the dark (anyone willing feel free but IMHO this is not acceptable either).
Sorry but no, sorry. I suggest you delete and re-do your post.
Mind the following posting rules this time please.

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

I fully agree with you!