openHABian frontail install error

I am trying to install Frontail on a fresh install of Ubuntu 17.10 via openhabian-config. Unfortunately, I get this error:

2018-01-24_21:40:30_CST [openHABian] Installing the openHAB Log Viewer (frontail)... 
$ npm install -g frontail 
npm WARN deprecated connect@2.11.0: connect 2.x series is deprecated
npm ERR! code 1
npm ERR! Command failed: /usr/bin/git clone --depth=1 -q -b master git://github.com/zipang/daemon.node.git /home/dome/.npm/_cacache/tmp/git-clone-cac570e3
npm ERR! /home/dome/.npm/_cacache/tmp/git-clone-cac570e3/.git: Permission denied
npm ERR! 

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/dome/.npm/_logs/2018-01-25T03_40_31_678Z-debug.log
FAILED (frontail)

I get the same error when I execute:

npm i frontail -g

I answered my own question - after a subsequent fresh install, the error message is more helpful. 17.10 (artful) apparently isn’t supported yet.

Using Lubuntu I ran into the same issue (“artful”)…

Try (with sudo)

apt install npm
npm i frontail -g

Then tested with

frontail /var/log/syslog

and it was working.

Nevertheless if you have a different host name than “openhabianpi”, it won´t work out of the box (known issue), as the device name in the startup screen is wrong.
Run

grep -i -w -R 'openhabiandevice' / 2>/dev/null

This will give you the file where the entry is wrong. For me it was

/srv/openhab2-conf/services/dashboard.cfg

Use e.g. nano to correct the link.

1 Like

To revise my previous answer:
It seems that there is an issue with node7.x no longer supported, switching to node 8.x did the trick and resulted in frontail being installed from the openhabian-config directly.

So i uninstalled node, then ran

sudo curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
apt-get install nodejs
sudo openhabian-config

In the optional components i triggered the LogViewer installation, this ran through without the previous errors.

After that Frontail is running on port 9001.

Hope this helps,
Thomas

1 Like

Unrelated to this content but may help someone given the title. I was having a repeated install error when reaching the install of Frontail on my raspberry pi 3 with the config tool. Moved to a different SD card and the problem disappeared, I think it had to do with the size of the card? The 2GB card failed but a 4GB card work.

Reviving this topic as I had the issue that I couldn’t install frontail on a fresh Openhabian (OH3) installation.
Here’s what I did, maybe it helps somebody at some point.

sudo apt-get remove nodejs
sudo curl -sL https://deb.nodesource.com/setup_12.x | sudo -E bash -
sudo apt-get install -y nodejs
sudo openhabian-config //install frontail
1 Like

Thank you @mancer . I have the same issue when installing frontail. Guess downgrade to nodejs 12 helps.