openHABian hassle-free openHAB Setup

raspberry
setup
openhabian
Tags: #<Tag:0x00007f6ce1a84580> #<Tag:0x00007f6ce1a84378> #<Tag:0x00007f6ce1a84210>

(Mark Leddy) #1241

I’m still struggling with this concept - I cannot find a way to install a functioning web browser on a pi set up with openhabian - I’m imagining lots of people have tried this - could somebody share a way of doing this. I’ve learned a lot about linux along the way but no joy. I have installed chromium-browser with no installation errors but cannot launch from the CLI. If somebody can share the commands to install a good choice of browser and confirm you can actually launch a suitable browser from the CLI I’d be very grateful. Otherwise I figure I need a second raspberry or something similar to run the touchscreen - I can do this but it seems a waste of energy (and money) if I can run openhab and a touchscreen off one Pi. All help much appreciated.


(Markus Storm) #1242

Well, that’s not what openHABian is built for, so that’s why few people (if any) tried this or will be able or willing to help.
openHABian comes with the HABpanel server part but it’s not meant to be the client, too.
Get a cheap Android tablet or used smartphone as your client(s).


(Mark Leddy) #1243

Thanks Marcus - I really appreciate a response. Now I know - HabPanel with another Pi it is. I can see leaving the Pi3 running just as the OpenHab server is a very clean installation so I’m happy to go with that advice. Wow it is sooo fast compared to the world of Mios and Vera that I have come from - if I am risking that then the little investment of another Pi is really worth it.


( ) #1244

Just to add some more context: http://docs.openhab.org/installation/openhabian.html#headache


(Jason) #1245

I had a pretty good openhab2 installation going using openhabian.

Then I noticed I hadn’t installed the Astro binding. Once I installed it using Paper UI, it uninstalled all my other bindings.

What happened?


(ThomasHupp) #1246

Hi

i had some trouble with my zwave on an openhabian installation after upgrading to OH 2.2.
So i decited to make a clean install with ubuntu 16.04 lts server i386 on my atom board.
all works well untill i come to the java installation.
openhabian setup itme 63 and 63a / zulu or oracle java installation both respond with an error:

Oracle java

Verbindungsaufbau zu download.oracle.com (download.oracle.com)|104.123.109.53|:80… verbunden.
HTTP-Anforderung gesendet, warte auf Antwort… 404 Not Found
2018-01-19 16:47:52 FEHLER 404: Not Found.

download failed
Oracle JDK 8 is NOT installed.

Zulu Java:

Ign:7 http://repos.azulsystems.com/ubuntu stable InRelease
Ign:8 http://repos.azulsystems.com/debian stable InRelease
OK:9 http://repos.azulsystems.com/ubuntu stable Release

E: Paket zulu-8 kann nicht gefunden werden. (german english translation: zulu-8 package can not be found)
FAILED

All other internet related updates and installations (apt-get update; apt-get upgrade / openhabian git installation; openhabian menuepoint 62 etc) went fine. So it is not the basic network configuration at fault. (gateway dns all checkt and working).

Is there some behind the curtens maintanence going on, on the java side of things?
Or am i just in trouble for installing the localiced german-cli version of ubuntu?

I have to say i’m getting a little frustrated at the moment. Let me stop myself

DISCLAIMER:
In no way i want to deminish the hard work and enthusiasm of the OH team. I know it is free, and for most of the team, they voluntary spend their free time on the project. So cudos to all of them.

continue wit the rant :slight_smile:
First i updated an openhabian OH2.1 installation with openhabain-config to OH2.2, and it destroyed my zwave config (but thats for a nother thread https://community.openhab.org/t/oh2-1-to-oh2-2-upgrade-dev-ttyacm0-does-not-exist-in-zwave-binding/38138/1).

Then i said to myself ok lets bite the bullet and do it right. (i foolishly installed ubuntu 64bit even i only have 2gb of ram, and after reading a lot about Nrjavaserial and 64bit problems on 64bit architectures, i thought ok lets go again from scratch)
I backuped my config started a fresh install, and now i can’t even get the basic openhab system installed. And this would be my 6th-7th openhabian installation on this hardware. So by now i’m a little familiar with the groundsteps :):grin:
And at the moment i’m getting a little furstrated with OH. I do on purpose no cuting edge stuff, no snapshots, no beta etc. I use the hassle-free openhabian and waited until 2.2 became stable.
But enough with the rant.

I like OH and all the things you can do with it. But at the moment it seams like i’m making one step backworth after the other, and none in the right direction :slight_smile:

cu all in 1h after i installed the english-cli version of ubuntu

Thomas


(Alan van Wyk) #1247

Minor bug report.

Openhabian install - with grafana / influxdb.
Loving the package - only issue is that the tiles all point to http://openhabian:3000

If you don’t have in house dns - or have multiple local networks, this means you have to restore the url each time (either use IP address or openhabian.local) else you have to do something like edit your local hosts file or setup in house dns.

Can this be changed to default to using the ip? Or be a redirect to the local page ?


(Frank) #1248

Hi Guys,

thanks a lot for the ton of work you did on this image! I am using it since the very first versions and it has only gotten better. Unfortunately, there is just one thing that makes me scratch my head repeatedly: Where can I find a list with the (current) default passwords please?

I am trying to use grafana, installed it via the openhabian-config tool and now I can’t figure out what the default pw ist. Openhabian:openhabian does not work, neither does openhabian:“myownpassword”, nor openhabian:habopen.

Searched for half an hour now on the forum and on the web but didn’t find anything that helps…

Thanks for the pw or a hint where to find it.

Cu


(SiHui) #1249

admin:admin


(Frank) #1250

Thanks a lot!


(Rob Kamp) #1251

I want to automate renewing the letsencrypt certificate that has been installed by option “43 | Reverse Proxy Setup Nginx with password authentication and/or HTTPS access”. I cannot find anything being added to the crontab for either root or openhabian.

Any suggestions or pointers?


(1technophile) #1252

@ThomDietrich
Hello,
I’m using openhab since 1.8 and discovered openhabian since 2.0, and I would like to thank you and all others contributers to this really efficient tool!
It makes the Openhab entry time cost very low now and the different options enables to setup a complete environement easily.


(Shorty707) #1253

hey there

got a quick question

  • I moved Root to USB with the option in openhabian-config
    -> the cmdline points to /DEV/SDA (the old way) instead of PARTUUID
    -> however this still works

-> now I copied /boot to a fresh fat16 formatted SD card

In the past this always worked since its a exact copy and just boots again from the USB storage
this won’t boot anymore however
reading on some forums they suggested to check the uuid with “blkid”… and change the cmdline… I already tried this. but openhabian still wont boot

when I put the original SD in again this still works

Anybody had problems there too? would like to have a boot on a small card

thanks!


(Shorty707) #1254

I think they issue could be there is now a UUID in fstab

so changing the boot sd causes this UUID to be wrong?


(Peter Juenger) #1255

Hi shorty707,

I’m not sure, but it sounds as if your boot-partition is referenced by uuid in fstab on your SDCard and maybe also on your USB storage.
Don’t confuse the boot partition (which always is on the SDCard) with the root partition (which is on your USB storage)

If your boot partition is referenced by uuid in the fstab and has changed (because you formatted your new SDCard and created a new filesystem on it) you have to adjust it then.

Alternatively you could clone your SDCard with dd (given that the size of new SDCard is equal or greater then the original), that should preserve the original uuid.


(Shorty707) #1256

I modified fstab accordingly.
However that still wont work.
The boot up just stops at “Attached SCSI Disk” and then stops
No error or can not find device message… strange.

The SD Card is a lot smaller. The whole process is:

  • Write Openhabian on “big” SD Card
  • Move root to USB
  • copy Boot to a very small SD Card

I did this before (raspbian jessie). No clue why it wont work here on the Stretch.


(Peter Juenger) #1257

Did you adjust the fstab on the SDCard AND also on the USB-Storage?


(Shorty707) #1258

the SD card only has /boot left
so no fstab there

really weird
32GB SD Card (also only boot left after I moved root to USB) + USB HDD works
512 MB SD Card + USB Hdd wont boot

maybe I try with vanilla raspbian and manual move to USB


(Peter Juenger) #1259

Yes, sounds like a good idea to first install a complete system (be it raspbian or openhabian) on your new SDCard and then adjust cmdline.txt and fstab manually.
Keep in mind to set “max_usb_current=1” in cmdline.txt if your USB storage needs more current.


(Jens) #1260

I installed everything a while a go and it worked fine so far. The last steps I took was playing around with habpanel.
Using habpanel I noticed I can not use openhabiabpi:8080 on my android device. It works fine on my windows devices but not on my android devices. Both are on the same wifi.
Has this something to do with he dns? Is there a way to use the openhabian:8080 domain on mobile/android devises?