openHABian hassle-free openHAB Setup

didn’t do the trick for me, it went ahead but simply stopped while downloading the packages.
Setting up via ethernet worked and I could enable wifi afterwards via openhab config tool.

Edit: Seems like there is a problem with bintray and the wifi connection somehow.
I get 403 forbidden error when trying to apt update over wifi.
Ethernet is working fine!

i send my post in another thread. i think its correct there ( openHABian v1.4 released! )

dumb question: how do I install openhabian 1.4 as it is no longer an image file? just copy the files on to the exFat formatted SD card and then insert into my Pi? For me at least this seems to not work…

edit: I found the right image file…

I’m still struggling with this concept - I cannot find a way to install a functioning web browser on a pi set up with openhabian - I’m imagining lots of people have tried this - could somebody share a way of doing this. I’ve learned a lot about linux along the way but no joy. I have installed chromium-browser with no installation errors but cannot launch from the CLI. If somebody can share the commands to install a good choice of browser and confirm you can actually launch a suitable browser from the CLI I’d be very grateful. Otherwise I figure I need a second raspberry or something similar to run the touchscreen - I can do this but it seems a waste of energy (and money) if I can run openhab and a touchscreen off one Pi. All help much appreciated.

Well, that’s not what openHABian is built for, so that’s why few people (if any) tried this or will be able or willing to help.
openHABian comes with the HABpanel server part but it’s not meant to be the client, too.
Get a cheap Android tablet or used smartphone as your client(s).

Thanks Marcus - I really appreciate a response. Now I know - HabPanel with another Pi it is. I can see leaving the Pi3 running just as the OpenHab server is a very clean installation so I’m happy to go with that advice. Wow it is sooo fast compared to the world of Mios and Vera that I have come from - if I am risking that then the little investment of another Pi is really worth it.

Just to add some more context:

I had a pretty good openhab2 installation going using openhabian.

Then I noticed I hadn’t installed the Astro binding. Once I installed it using Paper UI, it uninstalled all my other bindings.

What happened?


i had some trouble with my zwave on an openhabian installation after upgrading to OH 2.2.
So i decited to make a clean install with ubuntu 16.04 lts server i386 on my atom board.
all works well untill i come to the java installation.
openhabian setup itme 63 and 63a / zulu or oracle java installation both respond with an error:

Oracle java

Verbindungsaufbau zu (||:80… verbunden.
HTTP-Anforderung gesendet, warte auf Antwort… 404 Not Found
2018-01-19 16:47:52 FEHLER 404: Not Found.

download failed
Oracle JDK 8 is NOT installed.

Zulu Java:

Ign:7 stable InRelease
Ign:8 stable InRelease
OK:9 stable Release

E: Paket zulu-8 kann nicht gefunden werden. (german english translation: zulu-8 package can not be found)

All other internet related updates and installations (apt-get update; apt-get upgrade / openhabian git installation; openhabian menuepoint 62 etc) went fine. So it is not the basic network configuration at fault. (gateway dns all checkt and working).

Is there some behind the curtens maintanence going on, on the java side of things?
Or am i just in trouble for installing the localiced german-cli version of ubuntu?

I have to say i’m getting a little frustrated at the moment. Let me stop myself

In no way i want to deminish the hard work and enthusiasm of the OH team. I know it is free, and for most of the team, they voluntary spend their free time on the project. So cudos to all of them.

continue wit the rant :slight_smile:
First i updated an openhabian OH2.1 installation with openhabain-config to OH2.2, and it destroyed my zwave config (but thats for a nother thread

Then i said to myself ok lets bite the bullet and do it right. (i foolishly installed ubuntu 64bit even i only have 2gb of ram, and after reading a lot about Nrjavaserial and 64bit problems on 64bit architectures, i thought ok lets go again from scratch)
I backuped my config started a fresh install, and now i can’t even get the basic openhab system installed. And this would be my 6th-7th openhabian installation on this hardware. So by now i’m a little familiar with the groundsteps :):grin:
And at the moment i’m getting a little furstrated with OH. I do on purpose no cuting edge stuff, no snapshots, no beta etc. I use the hassle-free openhabian and waited until 2.2 became stable.
But enough with the rant.

I like OH and all the things you can do with it. But at the moment it seams like i’m making one step backworth after the other, and none in the right direction :slight_smile:

cu all in 1h after i installed the english-cli version of ubuntu


Minor bug report.

Openhabian install - with grafana / influxdb.
Loving the package - only issue is that the tiles all point to http://openhabian:3000

If you don’t have in house dns - or have multiple local networks, this means you have to restore the url each time (either use IP address or openhabian.local) else you have to do something like edit your local hosts file or setup in house dns.

Can this be changed to default to using the ip? Or be a redirect to the local page ?

Hi Guys,

thanks a lot for the ton of work you did on this image! I am using it since the very first versions and it has only gotten better. Unfortunately, there is just one thing that makes me scratch my head repeatedly: Where can I find a list with the (current) default passwords please?

I am trying to use grafana, installed it via the openhabian-config tool and now I can’t figure out what the default pw ist. Openhabian:openhabian does not work, neither does openhabian:“myownpassword”, nor openhabian:habopen.

Searched for half an hour now on the forum and on the web but didn’t find anything that helps…

Thanks for the pw or a hint where to find it.



Thanks a lot!

I want to automate renewing the letsencrypt certificate that has been installed by option “43 | Reverse Proxy Setup Nginx with password authentication and/or HTTPS access”. I cannot find anything being added to the crontab for either root or openhabian.

Any suggestions or pointers?

I’m using openhab since 1.8 and discovered openhabian since 2.0, and I would like to thank you and all others contributers to this really efficient tool!
It makes the Openhab entry time cost very low now and the different options enables to setup a complete environement easily.


hey there

got a quick question

  • I moved Root to USB with the option in openhabian-config
    → the cmdline points to /DEV/SDA (the old way) instead of PARTUUID
    → however this still works

→ now I copied /boot to a fresh fat16 formatted SD card

In the past this always worked since its a exact copy and just boots again from the USB storage
this won’t boot anymore however
reading on some forums they suggested to check the uuid with “blkid”… and change the cmdline… I already tried this. but openhabian still wont boot

when I put the original SD in again this still works

Anybody had problems there too? would like to have a boot on a small card


I think they issue could be there is now a UUID in fstab

so changing the boot sd causes this UUID to be wrong?

Hi shorty707,

I’m not sure, but it sounds as if your boot-partition is referenced by uuid in fstab on your SDCard and maybe also on your USB storage.
Don’t confuse the boot partition (which always is on the SDCard) with the root partition (which is on your USB storage)

If your boot partition is referenced by uuid in the fstab and has changed (because you formatted your new SDCard and created a new filesystem on it) you have to adjust it then.

Alternatively you could clone your SDCard with dd (given that the size of new SDCard is equal or greater then the original), that should preserve the original uuid.

I modified fstab accordingly.
However that still wont work.
The boot up just stops at “Attached SCSI Disk” and then stops
No error or can not find device message… strange.

The SD Card is a lot smaller. The whole process is:

  • Write Openhabian on “big” SD Card
  • Move root to USB
  • copy Boot to a very small SD Card

I did this before (raspbian jessie). No clue why it wont work here on the Stretch.

Did you adjust the fstab on the SDCard AND also on the USB-Storage?