openHABian hassle-free openHAB Setup

openHABian v1.4 released

Everyone! I’m super excited to finally present another iteration of the openHABian project. If your current setup is stable you don’t have to do anything. You could of course check out the latest improvements and additions :dizzy: If you run into any issues or have questions or ideas, please post them here!

Release Notes and New Images can be found in the Announcement → here ←

About the Future of openHABian - Contributors Wanted!

Over the first halve of 2018 I (@ThomDietrich) will not be able to invest any significant time into the openHABian project. We are therefore looking for interested developers to drive the project further! Development can go in many directions and part of this release was also to clean up and structure the code base for your easy start. You should bring basic bash and git experience, the openHABian project is an easy one to get stated with! If you are interested, drop a comment, contact one of the openHAB maintainers privately or directly push a PR our way :wink:

Check out the list of existing ideas or add your own:


When i am want to upgrade to stretch what do i need to do at least?A new installation?

Just follow the dist-upgrade instructions you can find here:
Should work without bigger problems.

1 Like


i have a problem with homegear installation from openhabian-config.
the following error occured:

$ apt -y install homegear homegear-homematicbidcos homegear-homematicwired
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
homegear : Hängt ab von: libgnutls-deb0-28 (>= 3.3.0) ist aber nicht installierbar
Hängt ab von: libmysqlclient18 (>= 5.5.24+dfsg-1) ist aber nicht installierbar
Hängt ab von: libssl1.0.0 (>= 1.0.1) ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Hello @RuHa,
this seems to be a bug related to the recent Stretch upgrade. A fix is underway, till then please install manually:

Thank you Thom.
if the fix is ​​made, where can I find the hint.

Please follow the github issue I’ve linked. The problem will be discussed and fixed there :wink:

sudo su
apt install apt-transport-https
curl | sudo apt-key add -
echo 'deb stretch/' > /etc/apt/sources.list.d/homegear.list 
apt update
apt install homegear homegear-homematicbidcos homegear-homematicwired

…worked for me. Thank you

For me it did not work. Even if I install it manually still get same mistake:
The following packages have unmet dependencies:
homegear : Depends: libgnutls-deb0-28 (>= 3.3.0) but it is not installable
Depends: libmysqlclient18 (>= 5.5.24+dfsg-1) but it is not installable
Depends: libssl1.0.0 (>= 1.0.1) but it is not installable
E: Unable to correct problems, you have held broken packages.

But do not see, what it is wrong.

Hello @hauna, just a wild guess but I if you followed the instructions by @Doxer blindly, you’ll now have both repositories registered in your system. There is a huge difference between > and >>. I’ve corrected @Doxer 's posting.Please try again

Thank you. Now working. Never ever would have seen the small difference:) Thank you both.

1 Like

Thank you

1 Like

Problems installing paho-mqtt

While trying to port my python scripts for simple mqtt clients in the current openhabian image,I found that the version of pip for python 2.7 is not working properly.
Following some advice I found on the internet, I had to uninstall the current pip version and install a more recent one

sudo apt-get uninstall python-pip
easy_install pip

after that I was able to install paho-mqtt

sudo pip install paho-mqtt

I searched through the topic but I did not find any reference to this, therefore I post it here. I hope that this may be of help to others.


just updated to 2.2 via openhabian menu and now a can’t “see” anything…
logs don’t show any activity, no paperui.
http://openhabianpi:8080/start/index only shows only cometvisu (not working anymore) and openhabian help.

any help?


openhab> bundle:list|grep -i pap
211 │ Resolved │  80 │ 0.10.0.b1              │ Eclipse SmartHome Paper UI, Fragments: 230
230 │ Resolved │  75 │ 2.2.0                  │ openHAB Paper UI Theme Fragment, Hosts: 211


sorry pulling up this old issue.

I just ran into it (its only my secondary install of OH :wink: )

the release info says “As always for existing setups there is no need to install openHABian anew. To be up to date you should however update openHABian and execute the “Upgrade” option. Next you can go through the menu and execute interesting options as you wish.”

So - is the “upgrade” from the openhabian-config fine and swtiches the system to raspbian based os … or is still the ua-netinst just prohibiting the upgrade of the problemativ apt?


After upgrading to from OH 2.1 stable to 2.2 stable from openabian-config on a raspberry pi 3, I can’t access openhabianpi:8080. I only get the error:


Problem accessing /start/index. Reason:

 Not Found

The log files are not being updated either (openhab.log and events.log).

When I run ‘openhab-cli info’ from the terminal I get the following answer:

Version:     2.2.0 (Build)

User:        openhab (Active Process 2011)
User Groups: openhab tty dialout audio gpio

Directories: Folder Name      | Path                        | User:Group
         -----------      | ----                        | ----------
         OPENHAB_HOME     | /usr/share/openhab2         | openhab:openhab
         OPENHAB_RUNTIME  | /usr/share/openhab2/runtime | openhab:openhab
         OPENHAB_USERDATA | /var/lib/openhab2           | openhab:openhabian
         OPENHAB_CONF     | /etc/openhab2               | openhab:openhabian
         OPENHAB_LOGDIR   | /var/log/openhab2           | openhab:openhabian


When I run ‘sudo /bin/systemctl status openhab2.service’, I get the following answer:

 openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled)
 Active: active (running) since Thu 2017-12-28 22:52:41 CET; 9min ago
Process: 1780 ExecStop=/usr/share/openhab2/runtime/bin/karaf stop (code=exited, status=0/SUCCESS)
Main PID: 2011 (java)
CGroup: /system.slice/openhab2.service
       └─2011 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab....

I have executed ‘Upgrade system’ and everything below ‘Apply Improvements’ from openhabian-config, as well as restarted the system.

Any ideas what could be the problem/solution?

All input is very appreciated, since I don’t know how to continue looking for a solution!

I got it working again by emptying the temp folders and rebooting, if someone else run into the same issue:

sudo rm -rf /var/lib/openhab2/tmp/*
sudo rm -rf /var/lib/openhab2/cache/*
1 Like

I etched the freshly downloaded 1.4 image to a brand new SD Card and put it into a brand new Raspberry Pi 3.
I edited the wifi settings in the config file and booted.
Unfortunately when I connected via SSH I found the following errors:

>     2017-12-30_16:18:29_UTC [openHABian] Updating repositories and upgrading installed packages... FAILED
>     2017-12-30_16:18:35_UTC [openHABian] Initial setup exiting with an error!

What is the problem here?

Multiple re-downloads and re writings to the sdcard didn’t fix the issue. However it seems to be a problem with the wifi setup. Connection is established but maybe there is no internet access.

Wired ethernet setup worked fine!

The same happened to me. It works on a Raspberry 2 but fails on a 3. I have no idea why.

What worked for me is to edit the script on the SD card (same folder as the openhabian conf file for the WiFi setup).

Look at these two lines from (

apt update &>/dev/null
apt --yes upgrade &>/dev/null

They “swallow” the error message and I removed the &>/dev/null part to diagnose. Once I did that everything worked fine though :frowning:

I’m an Openhabian and Openhab newbie - all is going well thanks to the information on the forums. I have the standard setup working. I have a HD touchscreen to run my main interface. Ideally I would like to connect the raspberry pi3 running openhab to the touchscreen and run Habpanel. So far I’ve the screen attached and displaying OK, however I guess I need to install a web browser on the raspberry as the final step. I’m a total Linux newbie! What would be the best browser to run Habpanel that would not compromise the performance of openhab?