openHABian hassle-free openHAB Setup

raspberry
setup
openhabian
Tags: #<Tag:0x00007fd31111a800> #<Tag:0x00007fd31111a698> #<Tag:0x00007fd31111a530>

(Miika Jukka) #1197

Could there be something wrong with your SD card? Have you tried formatting it? And maybe redownloading openHABian image before burning might solve this problem. Just to get rid of few basic error posibilities.


(Mike Hall) #1198

Thanks SO much for your reply and suggestions. I had reformatted and tried both RPI and Pine64 downloads, but used the same SD card. Today I reformatted a different card, downloaded a new image file, and it completed successfully!

It took 82 minutes to complete, so I may have interrupted before it was complete before. (patience is not my forte)

And thanks to Mr. Dietrich and everyone who contributed to this amazing tool! Now on to openHAB!


(Miika Jukka) #1199

Glad to hear you got it up and running!

P.S A like is always welcome if you find posts usefull.


(mlommers) #1200

just bought a new RPi3 and a pidrive and looking into using OpenHABian instead of installing all package myself for replacing my existing system.

Any tips on what would be the best approach to get the openHABian image installed on the HDD (PiDrive) instead of on the SD Card?


(Markus Storm) #1201

See http://docs.openhab.org/installation/openhabian.html#manual-setup .


(Joost Scholte) #1202

I have installed openhabian but i never get the options as shown in the attached image. I only get to choose between Paper UI and HabPanel.
Also in Paper UI/configuration/services/UI i can only choose HabPanel.

Anyone any idea what to do?

https://i.imgur.com/YdfdSo2.png


(mlommers) #1203

most probably you didn’t install other UI’s, this can also be done in the Paper UI:
Paper UI / Add-ons/ --> user interface
and install the user interface you want to add
In this way you should be able to add the basic ui, or any other available UI


(Joost Scholte) #1204

In Paper UI there is no UI section in Add-ons. Thats in Confurations/services/UI. And even there is only Habpanel


(mlommers) #1205

in configurations/services you can only configure what is installed, so if an items doesn’t pop up there, it means it isn’t installed and thus not able to configure.


(Joost Scholte) #1206

Sounds logical :slight_smile:
How do i install the extra UI’s? I can’t find them under add-ons. There is no UI tab.Only Bindings, Misc and Voice

https://i.imgur.com/z7YvTUi.png


( ) #1208

Hey Joost!
Pretty weird situation you are in. Did you try another openHABian install? At this point this might be the easiest step to get to the normal starting point. When you get to the initial setup screen, please select “Standard”.


(Garry Mitchell) #1209

Hi there,

I have been running 2.1 on a Windows box for a little while, but have come across some things where it appears it will work better on Linux, so have spun up a minimal Ubuntu Server 17.10 installation on my ESXi environment.

The basic have installed quite nicely using openhabian - I have a working OH Snapshot install, plus Mosquitto, but I am having issues trying to install InfluxDB and Grafana - it fails part way through the installation of these, but then flicks back to the the configuration tool, and I can’t seem to find a way to see the error message!

Influx seems to be partially installed - if I navigate via a browser to IP:8086 I get a plain text screen with “404 page not found”

As I am a total Linux n00b I thought this would be the quickest and easiest way to get a load of stuff up and running! I’m willing to find logs etc, but unfortunately I’ll need a little assistance on how to do so!


( ) #1210

Hey! Should be in general but the grafana and influx routine is quite honestly not mature yet.

Please follow this Tutorial, you’ll find a detailed step by step guide: InfluxDB+Grafana persistence and graphing


(Garry Mitchell) #1211

Hi Thom, thanks for your reply. I can certainly take a look at working through the steps in the linked instructions to get it up and running - but I’d like to assist if possible and highlight what has failed for me in the openhabian routine to help make it better! If there’s a way to get hold of the log from the failed installation attempt I’d like to post them up somewhere :slight_smile:


( ) #1212

They should have been visible after the installation. You just need to “Exit” the openhabian-config tool and scroll up. :slight_smile: Please open an issue with or also without in the issue tracker: https://github.com/openhab/openhabian/issues
I already have a good idea where the error came from. One would need to invest some work to improve the routine and I am sadly not in the position to do so currently.

Volunteers!!

Whoever wants to help with the InfluxDB+Grafana routine or any other improvement on openHABian, let me know and I can help you get you going.


(Garry Mitchell) #1213

Comparing the script with the individual installation instructions (for InfluxDB and Grafana), it looks like the InfluxDB installation is completed OK - but as I’m not running jessie, the repository & keyserver are never added locally - so apt install grafana will fail

I’ll add an issue on github with this info so it’s all in one place :slight_smile:


( ) #1214

Would you like try to fix this?
Edit… Oh!! You did already :smiley: Thanks


(Carsten) #1215

maybe a silly question but how can i access my installed mysql persistence on openhabianpi via an external tool :frowning:


(Joachim Boeddeker) #1216

First of all, thanks for openHABian. :smiley:

I have two slight additions: frontail for homegar and syslog. It is so comfortable not having to ssh anywhere and cat / grep the logs.

I added the following files to /etc/systemd/system

frontail-homegear.service:

[Unit]
Description=Frontail homegear instance, reachable at http://%H:9002
Documentation=https://github.com/mthenw/frontail
Documentation=https://github.com/openhab/openhabian/issues/28
After=openhab2.service

[Service]
Type=simple
ExecStart=/usr/bin/frontail -p 9002 --ui-highlight -l 2000 -n 200 /var/log/homegear/homegear.log
Restart=always
User=homegear
Group=homegear
Environment=PATH=/usr/bin/
Environment=NODE_ENV=production
WorkingDirectory=/usr/bin/

[Install]
WantedBy=multi-user.target

frontail-syslog.service:

[Unit]
Description=Frontail syslog instance, reachable at http://%H:10001
Documentation=https://github.com/mthenw/frontail
Documentation=https://github.com/openhab/openhabian/issues/28
After=openhab2.service

[Service]
Type=simple
ExecStart=/usr/bin/frontail -p 10001 --ui-highlight -l 2000 -n 200 /var/log/syslog
Restart=always
User=root
Group=root
Environment=PATH=/usr/bin/
Environment=NODE_ENV=production
WorkingDirectory=/usr/bin/

[Install]
WantedBy=multi-user.target

From my point of view, this is useful, if you share the opinion, you may include it into openHABian.
Maybe a frontail-expert could adjust a bit, i just simply copied the original frontail service.


Sending text to HM-Dis-WM55
(Joachim Boeddeker) #1217

If you are running windows, you may use mysql-front.

But i have no idea about the connection information.