openHABian v1.4 / v1.4.1 released!

Is your system installed onto a RPi / Pine64 or have you used the tool on a generic ubuntu dist?

When you run the script for the first time it ask for the system user so it can handle all changes correctly.
If that one somehow is incorrect these function will not work.

I’m on a Raspi3.
Do I understand correctly, when using “openhabian-config” initially (without sudo) I’m getting the message that sudo is needed, input with sudo, confirming with password and then it should NOT work?

1 Like

Then you are doing everything correct.
This sounds strange to me, do you get any error in the console while running the password change function?

No error. The passwoRd just didn’t change. Tried it two times and then changed it via passwd.

have someone an idea to solve this problem?


Hello Michael,
sorry for the late response. This is a bug which was also reported by another user. Please see here for the solution. Good luck!

After upgrade to 1.4 on my RaspberryPi2 OpenHabian does not work. Problem is probably related with MCP23017 binding. More information about this After upgrade from OpenHabian 1.3 to 1.4 OpenHab does not start - MCP23017



I just made the upgrade to Openhabian 1.4
It looks like everything went fine, only the start of the service openhabian did not work.
So I made a sudo shutdown -r, and openhabian came up as expected, also all functionality seems to be ok.

BUT, if I look to the logs, the last entries were the removing of things from the shutdown.
After that, no new entries!!! Nothing! What is going on here? And how can I find out why no logs are written?


I also commend you @ThomDietrich for the work you have done… much appreciated.

Maybe there is a place to report anomalies?

When running the menu item: install node-red, this happens:

--2017-12-23 16:14:50--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 19513 (19K) [text/plain]
Saving to: ‘/tmp/’

/tmp/ 100%[============================================================>]  19.06K  --.-KB/s   in 0.05s

2017-12-23 16:14:50 (356 KB/s) - ‘/tmp/’ saved [19513/19513]

$ bash /tmp/

Root user detected. Typically install as a normal user. No need for sudo.

**Are you really sure you want to install as root ? (y/N) ?**

Working Perfectly, Many thanks for the great job !!

I wonder what’s the correct procedure to switch from a older unstable 2.2 with openhab 1.3 to stable 2.2 and openhab 1.4? Also what to backup expect of /etc/openhab2, where does paperui store it’s configuration if I knew something up so I can restore it?

Thanks for a short how to

Before upgrading I would propose to make a complete image of your SD card, then you are always on the safe side.

I had a problem changing one of the passwords in the previous version via the command line when I was sure I did it right, but was able to change it via the console, so all good in the end.

Just checked my install notes it was the Samba password that refused to change from the command line.


I’v installed the new image and want to make is now happen. Because after several problems and installs it must be now the final version for some time :wink:

When i want to add the new z-wave controller and want to add the controller. I only can choose whats available. I cant write down my own serial port? Is that correct?
In the other versions i can write down the serial port i want. In this version i can only choose from a dropdown menu.
I know it is a verry dumb question… :blush:



No dont think this is correct. I have a RazBerry2 expansion card on my RPi3 ( thats the z-wave adapter i use ) and in this Serial Port field manually filling in the serial port is the only option.
I think the experts on this have to know what brand/type Z-way adapter you are using.

It is weird, each time you type it, it looks as if it is was not saved.
You cannot edit it again, but it basically works.

I might discovered a new bug.
I’m currently learning myself to add Things, Items and Rules manually. Would just mention that i if i remove a “thing” from the “.things” file it still is present in PaperUI Things. I also tried removing the .things file entirely but no changes in the Paper UI.Same goes with the Habmin Things. If i reboot it all disappear but that’s probably not how its supposed to work i would assume?


Ok only one issue I’ve run into … it seems my tiles have not updated with the FrontTail and Node tiles, even though I have them. I’m wondering if it has to do with the fact that I’ve already installed them, so OpenHABian isn’t installing them itself at this time. Aka, I upgraded from an older version. Not sure how you “track” which tiles to show?

I can attempt just going through the menus to install Node and FT again if that will trigger it?

The download link from bintray gives a forbidden message :frowning_face:

If i try to update the installed packages i see also a error 403 on the stable source in apt.

sudo apt-get update
[sudo] password for openhabian:
Hit:1 stretch InRelease
Hit:2 stretch InRelease
Ign:3 stable InRelease
Hit:4 stable Release
Ign:5 stable InRelease
Err:6 stable Release
403 Forbidden
Reading package lists… Done
E: The repository ‘ stable Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.