openHABian v1.4 / v1.4.1 released!

Thx for that. Now it works

Btw you should change your default password :wink:

Done :wink:

1 Like

Changing the system password (linux) didn’t work via openhabian-config, I had to use “passwd” instead. Am I missing a step?

I made a fresh install of the new openHABian 1.4 on sunday. I think openhab was still version 2.1 but I don’t realy know. After restoring/copying /etc/openhab2/ and /var/lib/openhab2/ all works fine.

But then I update openhab over openhab-config (think from 2.1 to 2.2) I get this error:

2017-12-19 20:12:29.013 [SEVERE] [org.apache.karaf.main.Main] - Could not launch framework
java.lang.RuntimeException: Could not resolve mvn:org.eclipse.tycho/org.eclipse.osgi/3.10.101.v20150820-1432
	at org.apache.karaf.main.util.SimpleMavenResolver.resolve(SimpleMavenResolver.java:59)
	at org.apache.karaf.main.Main.createClassLoader(Main.java:457)
	at org.apache.karaf.main.Main.launch(Main.java:254)
	at org.apache.karaf.main.Main.main(Main.java:179)


I decided to try this again…download openhabian 1.4, install (now it oh is 2.2) and restoring my files again and I get this error immediatly.

Any ideas?

Are you really referring to the system user ? I have that problem with the Samba password.
(and filed a PR to fix it for Samba).

2017-12-19_21:45:05_CET [openHABian] Changing password for samba (fileshare) account “openhabian”… Failed to add entry for user “openhabian”.
OK

Yes, the system password.
However I suspect the problem to sit in front of the screen. I was able to change that password in the previous edition, but I failed to get the one for the Karaf console changed. This time it was the system password, I didn’t even try the one for the console.
I’m starting the config tool with sudo, IMHO I can’t do anything wrong in the procedure to change a password.???

Is your system installed onto a RPi / Pine64 or have you used the tool on a generic ubuntu dist?

When you run the script for the first time it ask for the system user so it can handle all changes correctly.
If that one somehow is incorrect these function will not work.

I’m on a Raspi3.
Do I understand correctly, when using “openhabian-config” initially (without sudo) I’m getting the message that sudo is needed, input with sudo, confirming with password and then it should NOT work?

1 Like

Then you are doing everything correct.
This sounds strange to me, do you get any error in the console while running the password change function?

No error. The passwoRd just didn’t change. Tried it two times and then changed it via passwd.

Hi,
have someone an idea to solve this problem?

Regards
Michael

Hello Michael,
sorry for the late response. This is a bug which was also reported by another user. Please see here for the solution. Good luck!

After upgrade to 1.4 on my RaspberryPi2 OpenHabian does not work. Problem is probably related with MCP23017 binding. More information about this After upgrade from OpenHabian 1.3 to 1.4 OpenHab does not start - MCP23017

Regards
Michal

Hi,

I just made the upgrade to Openhabian 1.4
It looks like everything went fine, only the start of the service openhabian did not work.
So I made a sudo shutdown -r, and openhabian came up as expected, also all functionality seems to be ok.

BUT, if I look to the logs, the last entries were the removing of things from the shutdown.
After that, no new entries!!! Nothing! What is going on here? And how can I find out why no logs are written?

Holger

I also commend you @ThomDietrich for the work you have done… much appreciated.

Maybe there is a place to report anomalies?

When running the menu item: install node-red, this happens:

--2017-12-23 16:14:50--  https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/update-nodejs-and-nodered
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.96.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.96.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 19513 (19K) [text/plain]
Saving to: ‘/tmp/update-nodejs-and-nodered.sh’

/tmp/update-nodejs-and-nodered.sh 100%[============================================================>]  19.06K  --.-KB/s   in 0.05s

2017-12-23 16:14:50 (356 KB/s) - ‘/tmp/update-nodejs-and-nodered.sh’ saved [19513/19513]


$ bash /tmp/update-nodejs-and-nodered.sh

Root user detected. Typically install as a normal user. No need for sudo.

**Are you really sure you want to install as root ? (y/N) ?**

Working Perfectly, Many thanks for the great job !!

I wonder what’s the correct procedure to switch from a older unstable 2.2 with openhab 1.3 to stable 2.2 and openhab 1.4? Also what to backup expect of /etc/openhab2, where does paperui store it’s configuration if I knew something up so I can restore it?

Thanks for a short how to

Before upgrading I would propose to make a complete image of your SD card, then you are always on the safe side.

I had a problem changing one of the passwords in the previous version via the command line when I was sure I did it right, but was able to change it via the console, so all good in the end.

Edit:
Just checked my install notes it was the Samba password that refused to change from the command line.

Hello,

I’v installed the new image and want to make is now happen. Because after several problems and installs it must be now the final version for some time :wink:

When i want to add the new z-wave controller and want to add the controller. I only can choose whats available. I cant write down my own serial port? Is that correct?
In the other versions i can write down the serial port i want. In this version i can only choose from a dropdown menu.
I know it is a verry dumb question… :blush:

image

image

No dont think this is correct. I have a RazBerry2 expansion card on my RPi3 ( thats the z-wave adapter i use ) and in this Serial Port field manually filling in the serial port is the only option.
I think the experts on this have to know what brand/type Z-way adapter you are using.